Fedora 36 KDE and DP MST hub

Good day folks!

I’ve been attempting to get a docking setup going for the Framework and ran into some hiccups. Before beginning, it’s worth noting too this exact setup works just fine on my home PC setup which is Fedora 36 Kinoite with an AMD GPU/CPU.


  • Framework running Fedora 36 KDE
  • 3 monitors plugged into a StarTech DP1.2 MST hub
  • MST hub plugged into a KVM switch
  • KVM switch plugged into my Desktop PC (Display Port) and the Framework (USB C)

With this setup, I can see all the monitors and their names just fine on the Framework in the Display Configuration menu, but all of them show “No Signal”.


  • Tried running a DP-DP cable to the Framework that I knew worked with my main PC - same issues as with the USB C cable.
  • Tried running a single HDMI cable for my main monitor (not connected to the MST hub), that works fine.
  • Hot-plugged the HDMI + the MST hub, froze the laptop and required a restart. To Framework’s credit though when I got back in it automatically disabled the Laptop monitor and had the other 4 enabled which is pretty cool

In all the above troubleshooting cases I got the same result consistently - I could see the 3 other screens I’d expect to see a signal on, but I couldn’t actually see an image. Hoping somebody has some insights into this; thank you in advance!

I’m having similar enough issues with my laptop.

Do you have an HDMI expansion card? Do you get output to your monitors using that? I don’t.

I do, though I haven’t tried it because I don’t have a compatible cable. If I recall correctly, DP → HDMI cables need to be ‘active’ cables rather than passive ones for them to work correctly in some configurations. I know only enough about that to recognize I should probably avoid it.

To answer a similar question, I have also tried this with a display port expansion card and hit the same issues.