Public Beta Test: 11th Gen BIOS v3.06 + Driver Bundle 2021_10_29

Normally I’d be hesitant to do that, as the way framework has those modules implemented on the mainboard is going to vary from application to application. Hence the drivers they provide could be specific to that implementation. Otherwise, wouldn’t they tell us to just use the ones straight from Intel?

Still have you seen improvements? About the only thing I want is standby improvements.

1 Like

Framework bundles the drivers they’ve extensively tested and confirmed to work, so you can get every part of their eponymous laptop up and running on a clean install, but ‘not the recommended version’ is far from ‘incompatible’. Framework’s laptop is a modder’s dream, and it can be your dream too if you dare to dream it. And troubleshoot it.


So far so good on Windows 11 (22000.282). Both BIOS and driver bundle installed. A cool feature in the future would be the ability to create a custom fan curve in the bios for the cooler. Maybe with safeguards in place so someone can’t purposely cook their CPU. Thanks for the hard work Framework!


Just an FYI for others who might have any issues:

I installed the BIOS update using a Windows To Go drive, which worked fine for BIOS 3.03. It rebooted fine, and it went through the install like normal. After doing the EC update, it hung on “Update status: Complete”. I left it like that for about 30 minutes, and no change. I just tapped the power button (tapped, not held), and it turned off. I turned it back on, and was greeted with a black screen for about 25 seconds. After that, the normal Framework post screen came up, and it tried to start.

However, it just threw me into a Windows blue error screen (A required device is not connected). I rebooted to try and change my boot settings, only to notice that my Linux boot entry was gone (Arch on my NVMe drive), and it was listing Windows Boot Manager on the NVMe drive, while in actuality there’s no Windows EFI data on my internal drive, it’s all on the expansion card. I removed the expansion card, had no effect.

I tried an Arch USB, to reinstall my boot entry, but I then discovered that no new boot devices showed up whatsoever. Also, while I was in there I tried the power button dimming option in the bios when I first rebooted (it’s why I updated), and it didn’t have any effect. Still the same brightness.

At this time, I started to panic a little. I opened up the laptop, and I wasn’t greeted by the normal flashing LEDs when I first opened the chassis. Completely dark. I disconnected the battery, then (very carefully) removed the CMOS battery, waited a few seconds, and put it back in. I then reconnected the battery, and upon turning the machine on (and going through another memory training), everything is normal again. I was able to boot into an Arch USB and reinstall the boot entry, and the new power button dimming feature works perfectly now.

Hope this helps if anyone else has the same issue. It might be my fault for pressing power (given that it tells you explicitly not to do that in the initial program), but I didn’t know what else to do after it hung for a long time with seemingly no change.


Awesome :slight_smile: Thanks for the highlight.

Waiting for the drivers on LVFS though som might take a while before I get the update :smiley:


I got an error “The BIOS image to be updated is invalid for Secure Flash or onboard BIOS does not support Secure Flash.”

I have no idea what caused it and no idea how to resolve it. I seem to be the only one to have encountered it since no one else reported this.

Secure Boot setting? Something else?

My Framework has been running pretty much perfectly so I didn’t work at it much, but I would like to try out these beta BIOSes.

If it does work for you please let me know.

1 Like

I’m actually planning to install Windows on USB using DISM. Basically circumvent the installer’s refusal to install on removable storage. I’ve tried this approach once and it worked. I have not tried flashing BIOS from it.

1 Like

Ooh that does sound scary. I think I’ll wait until the BIOS update is finally on LVFS and play it safe.

Actually your experience with Windows To Go is similar to mine on my desktop. WTG turned on Secure Boot somehow, put itself and only itself on the approved drive list and on reboot I could no longer boot from my Linux Mint drive. I couldn’t boot from an LM install drive either so there was about 10 attempts turning on and off Secure Boot, wiping EFI keys, trying to find the install drive, etc. Finally I was able to reinstall but I lost all my data. Thank goodness for backups!

I vowed “never again” but I need it for SSD firmware updates on my desktop and my Framework so I have to risk it again. It did not destroy my install on my Framework but would not update the BIOS.

1 Like

Nice. I used Rufus which worked well but it needs to be done from a fairly powerful Windows computer and since I’ll be selling it, I have to come up with something else. I created it “UEFI + CSM” this second time which did not destroy my Framework install, so maybe it’s safe now. But I have to keep it permanently because I’ll never be able to write it again, I’m having problems using USB devices from a Windows VM.

So as not to drag this important thread off-topic, maybe I should explore this further in the Off-Topic section.


Not hardly, it was already in the works… As mentioned in other communications.

Patience is the key…


That’s why I had the /s at the end, which you excluded from your quote. Sarcasm.


Grin, not everyone on the face of the earth knows what /s or all of the myriad short annotations mean. Hence, I never use them.

I work on the lowest common denominator concept when it comes to writing…



Good job man, who knows whether the BIOS update would have happened without your video. Keep up the pressure.

I like Framework and believe in Right to Repair, and I like your YouTube channel.


I think I’ve said enough on the other thread about how I disagree with this sentiment.

I am happy that Framework was able to provide a solution so quickly, and because of how software development works, my guess is the video had VERY little to do with it, as this was probably in the works for a while BEFORE the unnecessary video was ever made.


This is the last I’ll comment on this outside of my own platform as it is distracting from the original topics of the threads. I’ve already posted my final thoughts on my community tab. I will likely touch on some of these listed issues in my long term review (> 6 months) of the laptop but they are not issues that require a dedicated video. Those are typical problems that new hardware and developers encounter. None of that was promised to be perfectly implemented prior to launch. The ability to run the mainboard free of the battery was. Most notably to the User who asked the direct question and was answered directly by two members of the Framework staff with misleading information. I have apologized for letting my disappointment get the better of me concerning my comments about e-waste and unlisted the video. I have no ill will towards Framework, they made a mistake and now it’s fixed which is much more that most companies. I hope at some point they answer my original question concerning the discrepancy but I do not feel owed that. I’m moving on to create the content I had originally planed too.


Totally with you there, I’m going to test later today on that. Although given it wasn’t called out, I don’t think modern standby is going to last more than a couple of hours before the 5% cap is breached and windows goes to hibernate

1 Like

Fingers crossed for the next update then. Although I’m hopeful that the 0.39ghz problem would also be solved in the next update

1 Like

I’ve updated to the BIOS without issues. Upon reboot however, the system boots up windows instead of Grub. I have to manually hit F12 and pick Ubuntu to get the boot loader. In the BIOS settings under boot order, there are no options to edit anything.

Any ideas what the solution is ?

1 Like

Has Secure Boot been reactivated?

1 Like

@WBWBW go to boot page in the bios, and change boot order from auto to first/last, and you will get a submenu at the bottom of the boot page to adjust the boot order.
First/Last means prioritize first device that was detected/or last device detected. Eg prioritize a new thumb drive over the internal ssd.