Random hard freezes fw13 amd7840u win11

Just a note on DPC_WATCHDOG_VIOLATION specifically. As you can see from the assortment of debug paths and resolutions from this thread, we haven’t seen any single root cause, but rather a catchall in Windows for any of a number of possible root causes. If you are running into this, please reach out to support.

Note that because there isn’t a single root cause, this makes the debug process require more steps with support than most other types of issues. We start with the least burdensome steps (which are also the ones that generate the least waste), and then go by process of elimination through each possible cause. This means we start with software and driver checks, then checking reseating memory and testing with one stick at a time to determine if one is bad or a socket on the mainboard is bad. The last step if none of those were the root cause is a Mainboard swap.


Hey NRP. This is the first time anyone from Framework has said anything outside of support about this very obvious issue. Across Reddit, Microsoft Answers and this community, countless people are having this issue and quite a lot are yet to reach out to support.

Do you not feel that it’s time Framework made a proper public acknowledgement of this issue? Even if it’s to say “listen, we know this is a thing, we don’t know yet what is causing it, but we’re working on it”

Consumers deserve all the information they need to make informed purchasing decisions before choosing an AMD configuration, and many, me included, aren’t too happy with essentially being beta testers. My work commitments don’t afford me this luxury and I use my Framework laptop for work purposes.

I’m fully behind Framework and your mission, but transparency is key and only fair.


In my cases, all has happened under smallish loads. Browsing, Microsoft Word, Discord and when using Microsoft Phone Link to do some business expense claims :sweat_smile:

Can’t say if that is a cause or not since that’s the main use cases for the laptop is browsing, word documents, social use, or maybe web/photo editing and media consumption for when I’m on the move.

I haven’t used the laptop this weekend, it has been sat on sleep, so I’ve no updates since last post.

1 Like

Don’t you think that is what @nrp has done in the post immediately before yours?


Of course, given the nature of my problem, (aka no consistent steps to reproduce) I managed to trigger it again today, with just my “good” stick of ram in the system. I am going a bit crazy on this issue, to the point that I broke out WinDbg and cracked open the memory.dmp from this latest crash.

SYMBOL_NAME:  amdacpbus+6c53a

MODULE_NAME: amdacpbus

IMAGE_NAME:  amdacpbus.sys

STACK_COMMAND:  .cxr; .ecxr ; kb


FAILURE_BUCKET_ID:  0x133_DPC_amdacpbus!unknown_function

OS_VERSION:  10.0.22621.1

BUILDLAB_STR:  ni_release


OSNAME:  Windows 10

FAILURE_ID_HASH:  {79fc37ef-989d-4595-4c29-e34964a8cc54}

Followup:     MachineOwner

3: kd> lmvm amdacpbus
Browse full module list
start             end                 module name
fffff800`8f190000 fffff800`8f753000   amdacpbus   (no symbols)           
    Loaded symbol image file: amdacpbus.sys
    Image path: \SystemRoot\System32\DriverStore\FileRepository\amdacpbus.inf_amd64_22f1166a5ad4ea7f\amdacpbus.sys
    Image name: amdacpbus.sys
    Browse all global symbols  functions  data
    Timestamp:        Sun Aug  6 23:14:42 2023 (64D08BD2)
    CheckSum:         005CCADE
    ImageSize:        005C3000
    Translations:     0000.04b0 0000.04e4 0409.04b0 0409.04e4
    Information from resource tables:
3: kd> dt nt!DPC_WATCHDOG_GLOBAL_TRIAGE_BLOCK fffff8004a71d340
3: kd> dt Wdf01000!DPC_WATCHDOG_GLOBAL_TRIAGE_BLOCK fffff8004a71d340
   +0x000 Signature        : 0xaebecede
   +0x004 Revision         : 1
   +0x006 Size             : 0x10
   +0x008 DpcWatchdogProfileOffset : 0x88a8
   +0x00c DpcWatchdogProfileLength : 0x8200

The driver that appears to to have been involved in the chain is loaded by AMD Audio CoProcessor. (Thanks Device Manager for finally having a View by Driver option).

At the time of this crash I had an HDMI expansion card installed. No external devices installed. On battery power. Watching video via Firefox.

As requested by @nrp , I do have a ticket going with support going (and it’s getting long). I do want to keep providing others in the thread updates about my findings (especially final resolution) as this one seems rather tricky.

For @lane_ftw
Ram: Framework 16gb DDR5-FRANRM0002 / 0016G-BFW
Windows 11 22631.2861

Slot 1: USB C
Slot 2: USB A
Slot 3: USB C
Slot 4: HDMI


I posted a few weeks ago in this thread with the same behavior, always crashing under light load in MS Edge (3-4 tabs open, no video or games) with the DPC_WATCHDOG_VIOLATION. Sometimes, the mouse would lock up and after 30 seconds or so it would start working again but usually after being locked up for about 90 seconds it would BSOD. The crash dump files pointed to the amdgpio driver as the problem.

I ran memtest, various system stress tests, reloaded drivers lots, ran sfc /scannow, checked my drives, etc. At one point, I updated the Realtek Audio drivers as mentioned earlier in this thread. Around that same time I switched to Firefox. Ever since then I have not had a BSOD and it’s been a few weeks. @nrp is correct, this could be anything! For some people it could be RAM, for others drivers, and maybe for some a new motherboard.

For reference, I am using the G.Skill RipJaws 2x16gb DDR5-5600 CL40 kit and a Solidigm SSD. Slots are USB-C, USB-C, USB-A, and HDMI. I never opened a ticket… figured I shouldn’t waste their time since it working for me now.

Hey Alan, I meant somewhere visible on the site, rather than hidden away in a forum thread that’s some 100+ responses in. I feel that consumers need all the information they need before choosing a AMD framework. Had I known what a hassle it would have been to own it, I would have chosen something else, even if that was an Intel framework

1 Like

For everyone else’s benefit, support asked me to run on one stick of RAM in slot 0. I’ve done this with each stick (Framework-provided DDR5-5600 - 16GB (2 x 8GB)) but the problem persists.

Updating support with my findings. I really wish I’d gone for 2x16 - running on 8GB has been awful - running my laptop like it’s 2014!

I have been struggling with crackling/static audio on only one of my audio input devices. My audio technica AT2020USB microphone. After waking up from hibernate, and multiple times through the day I have to go into Sound recorder and do a sound-check on my microphone to make sure it hasn’t reverted back to static/terrible quality.

The other day when this happened, I went into device manager and disabled this “AMD-Dynamic Audio Noise Suppression” device and my audio reverted (I already had confirmed that inside the AMD software noise reduction/suppression wasn’t enabled).

But then the problem recurred. For some reason it’s always the microphone input from the AT2020USB+, never the Logitech C920 webcam.
One thing that was throwing me off is that elsewhere in the Device Manager, the USB Microphone input appeared to be using Microsoft drivers,

but then when I would go into Settings, it was showing that the AT2020USB was using AMD drivers:
(This screenshot now shows the generic driver I assigned, instead of AMD in the upper right corner

I was able to switch the AT2020USB+ to generic drivers from the “Sound, video and game controllers” section, but the problem returned again.
Now I have Disabled all of the AMD Sound controllers (AMD BT Audio Device, AMD High Definition Audio Device, AMD Streaming Audio Device, AMD USB Audio Device)-> After disabling the AMD USB Audio Device, it said that I needed to reboot the computer. :

So far the problem hasn’t come back today, but time will tell.

If I could figure out this problem, and my problem where both of my Thunderbolt 4 docks (Dell and Lenovo) have to be unplugged and replugged every time I wake up the laptop in order for app switching from the taskbar to work (a new problem since the last week of December) I’d be a pretty happy camper with my Framework 13 AMD. (Well, also if sleep would actually work and stay asleep so I didn’t have to use hibernate if I didn’t want a dead battery or a cooked laptop in the bag.)

My concern with it being potentially the RAM is that it is something I got from another seller (not from Framework itself) and so wouldn’t be able to be returned unless I can find someway of demonstrating it as a memory issue.

Theoretically though, all RAM sticks should fundamentally be compatible with any system (speed settings and controller limitations notwithstanding). QVL lists are mainly to say that this RAM has been tested and verified as compatible. Laptops though tend to have the motherboard configure the RAM speeds automatically for stability anyway… at least I assume so. Unlike desktop motherboards, you can’t really alter any of the RAM speed settings yourself.

You also shouldn’t expect utility software itself to cause bluescreens, unless there’s some fundamentally dodgy programming causing a memory leak or some other critical bug. Have had driver issues on other systems but those were so more easily fixed with a rollback. For those reasons, I’m a bit surprised Framework doesn’t offer older drivers in case of stability problems.

I haven’t been on my laptop all that much recently, so I still have nothing to report on the issues yet.

Like danweast I am having success with disabling hardware acceleration in chromium-based applications. I haven’t been getting blue screens after disabling it on Discord. As a side note, I am using Firefox version 121.0.1 with no Spotify client installed.

There are reports of similar behaviour with multiple AMD GPUs on different sites. They are quite old, but I believe they still apply to the newer drivers in some cases. I haven’t done enough testing to confirm anything, but I just wanted to document my own experience. Personally, I’d have no problem keeping it disabled if needed.

I am also having the issue with the buzzing speakers after waking up from hibernate as lane_ftw mentioned earlier in this thread.

I think the problem is that the DPC_WATCHDOG_VIOLATION error covers a plethora of driver issues that can arise from either bad drivers, bad firmware, or bad hardware. It’s kind of a catch-all (somewhat defeating the purpose of error messages but c’est la vie…).

1 Like

I also have the same problem without any BSOD and event in event viewer.
I notice it will happen when I start a specific game in windows. It almost happen everytime.
The system is freezed. Sometimes will still can hear game music from speaker, but cannot do anything.

I had tried to switch both BIOS and AMD driver graphic memory setting. Nothing improves.
I use both windows and nixos. Only windows happened this problem.

Because there is no event and log, I have no idea how to do further analysis.
The memory is A-data DDR5-5600 32G*2. Already passed memtest86+.

When the computer freezes, please wait and see if a BSOD appears, be sure to mark down any error messages displayed on the blue screen.

If it is not a DPC_WATCHDOG_VIOLATION, then it is not the same issue. How do you know it’s not an issue with the game itself? If it only occurs with that specific game, then it is likely the game is at fault, not necessarily your laptop. The fact that there is nothing in event viewer is strange…

On my system, it will freeze for up to three minutes before actually triggering the BSOD. I assume most users will force restart before that point.

In such a case event viewer will likely show only an unexpected shutdown and nothing else

I waited more than 2 hours. It just freeze. No BSOD. No response.

Yes, it may not be the same root cause as “DPC_WATCHDOG_VIOLATION”.
The game is also not an AAA game or some heavy resource game. I’m also not have the freeze issue in game but in using browser or do other thing. I just found it is the easiest way to reproduce the issue.

The only strange in event viewer is “Display driver amdwddmg stopped responding and has successfully recovered.”. But it does not recovered freeze.

I’ve had this issue since I got this laptop as a part of batch 2. I originally posted on Reddit about this issue, but was not able to solve it.

Since then, I’ve had a (extremely infuriating) conversation with framework support, wiped the laptop and put a fresh install of

Ubuntu 23 (did not crash, but had issues with display strobing white after waking from sleep),

Ubuntu 22 (same issue as Ubuntu 23),

and now back to Windows 11. After my most recent fresh install of Windows 11, it ran fine for the first week, then I had a bluescreen, then it was fine for 2 weeks, and now just tonight I had another DPC_WATCHDOG_VIOLATION bluescreen.

As many of you probably are feeling, I love this laptop, but this process has been incredibly frustrating, and I am ready to throw this thing out the window.


oh this is the same issue I have had, have submitted a ticket with heaps of info, minimal response from Framework.

People getting BSOD in Windows, please run WhoCrashedMe from Resplendence Software - WhoCrashed, automatic crash dump analyzer

See also 7840U, Windows 11 23H2, BSOD in msgpioclx.sys

I definitely get you here. I use mine for work, I just can’t rely on it.

1 Like