Requesting a couple details for eyes-free framework DIY installation

Oh, that would have been really nice. And since it already needs to be shaped, it might have been close to free, besides the extra effort to verify the design. Though making new molds now is probably costly. Hope they can do that when a new design is needed.

I’m not so sure any braille or tactile markers denoting certain areas would be needed, you can generally figure out which area does what by how they feel. Ram is different than an M.2 2230 slot, which is different than an M.2 2280 slot. And, if various connections on the mainboard are different as well, those can also be identified, since they would theoretically only work with what they’re designed for. I’ve never worked on a laptop beyond replacing a hard drive, but I’ve worked on desktops before, the principles of locating items would undoubtedly be similar. Unfortunately, since braille isn’t commonly placed on computer components, this would probably drive up the cost more than it might otherwise be.

That is skipping one important detail: people who’ve never seen these slots before will not have any clue which one’s which. I was able to find the ram slots because they have mylar over them. Even with instructions in this thread though I can’t find either part I asked about for the life of me, though. So I wouldn’t say it’s quite that cut and dry.

The SSD slot and the mainboard touchpad / input cover connector?

For the SSD, to add to what next_to_utter_chaos said, the SSD slot is at the very bottom middle of the mainboard. It might help to find the cpu fan, middle left on the mainboard. Above the fan are two flattened tubes. They are right next to each other, touching, these are the heat pipes. They travel to the right and curve to point downwards, away from the display, and each pipe has a small pip at the end. They end right above the SSD slot and point to it.

The SSD should have an off-center notch cut out of its connector end. When the SSD is facing up, in the right orientation to be inserted, the notch is towards the battery. The mainboard connector has a peg that fits into this notch, which you should be able to feel.


The SSD slot (I describe it when empty) is just at the bottom of the mainboard, and centered slightly on the left. (By the way the bottom of the mainboard is not the bottom of the whole, because there is the battery sitting at the bottom of the mainboard. So I meant just above the battery.)
The SSD slot is a smooth rectangular area of around 65mm length (horizontally) for 20mm height.
On it left is a screw thread (that serves to secure the SSD when installed) and it protrudes about 2mm.
On its right is the SSD connector per se. It is a M.2 connector. Its around 5mm wide (horizontally), 20mm height (vertically) and around 3mm thick.

The leftmost screw thread of the slot is below the CPU fan (a circular feature, with apertures through which you could sense the fan blades rotate), but around 15mm on the left of its exact middle point. And its around 15mm below the bottommost point of this fan assembly.


Yes it is meant to come out all the way!

These are both extremely detailed instructions that provide a lot of good information someone could feel. Just reading these, I appreciate the time and thought that went into these descriptions, it makes me more confident about potentially getting my own DIY one day.

Thank you.


@Blake_Galbraith Extremely glad to help, and I believe this feeling is shared by all the other posters!
I think you can count on the community for that.

1 Like

Oh hey, are you aware that there seems to be an upcoming braille laptop which is supposed to use the Framework mainboard? Framework’s CEO, Nirav Patel, mentions it during the Framework Next Level Event | 2023 Launch Event at 1 minute 27 seconds. Time link:

It’s from a company named Orbit Research. Though oddly, Orbit doesn’t appear to mention that it uses the Framework mainboard on their page about it. But the images match what Nirav showed exactly, the specs match too.
I don’t see a price, just a form to submit for them to inform you when it’s ready to ship. I imagine it will be a good bit more expensive than just a regular Framework.

@junaruga found a couple links about it.

One link mentions, “It is the only product that puts users in complete control by offering them complete configurability before they purchase it and full upgradability after.”

1 Like

Sort of. Typically the SSD works best inserted at a slight angle (less than 45 degrees), then rotates to flat. I think they do this to protect the pins in the connector from sliding forces, instead they just have to deal with spring-like force as that part of the board pivots up towards the pins. The mechanism that contacts Nintendo Entertainment System cartridges do this a bit as well- the cartridge ramp will accept the cart then pivot slightly when the user presses the mostly-horizontal cartridge completely flat.

The WiFi card behaves very similarly. In fact the RAM also goes in at an angle, but there are little clips that will click into place once the RAM is rotated flat. The NVMe SSD has a tiny notch dividing the connecting edge roughly 90/10, the smaller of which should be furthest from the screen hinge and the notch opening pointing right. The NVMe SSD is thus inserted left-to-right on this board. The WiFi card is inserted right-to-left with the connecting pins divided about 60/40 with the shorter set again being furthest from the display hinges. Some WiFi cards have multiple notches, in which case your best bet is to try and feel the two tiny antenna connectors, which should be on the upward side of the board and away from the connecting edge.

Going overkill on the description, just in case anything else was missing from the guide.

1 Like

These are also great descriptions to assist with DIY or component replacement.

I am aware of the Optima Braille Laptop, but that’s off the topic of this topic, and would already come pre-assembled, anyway.

Though it’s not really needed any longer, would anyone be able to describe how to insert an RTC battery on the mainboard? Are there any tactile indicators on an RTC battery that might assist with proper orientation of the battery when inserting it?

Thanks once again for all the responses from everyone.

The RTC battery is a ML1220 (before I had started CR2032, which is incorrect) that should be positive side up when inserted. The positive side is completely flat, but the negative side has a slim ring around the perimeter and a slight… chamfer? Bevel? The corner is rounded. You should be able to feel the ring with a fingernail.

Battery insertion also starts at a slight angle with the flat side up and the initial corner inserted being furthest from the hinge. There are two small plastic tabs that will hold in the “south” end of the battery and a metal clip on the “north” end. Depending on parts supplier, this may differ slightly, but if in doubt understand that to remove the battery the metal clip is pressed away from the center of the battery and the battery will pop up because the conductor at the bottom of the battery “socket” is bent slightly. If you can find the metal clip side, start the battery on the opposite end (still positive, flat side up). If the battery is placed correctly, you will push down until that clip slides over the flat edge of the positive side of the battery, holding it secure. The battery should not be able to slip side to side when you are ready to push it down, unless you use enough force testing side-to-side to have it slide up and over the edge of the socket.

BTW, the downward force to insert the battery is straight onto the mainboard, not downward toward the south end of the board, Press like the coin cell battery is a button.

Beware, the RTC battery holder can break if too much force is used. Probably more likely when trying to remove a battery though, as you need to kind of leverage it out, if I recall correctly. It seems some people have cracked theirs.

A little off-topic: 11th gen and 12th gen use both a smaller ML1220 as rechargeable RTC battery, I would have expected the 13th gen Intel to stick with the same size for its optional RTC battery. Did the mainboard design change that much, so a bigger tray for a CR2032 could fit in?

1 Like

They announced their collaboration with Framework in the new release. You can see the latest news in the page below. (There is no specific link for the news article. Inconvenient web design.) -
Announcing the Integration of the Framework Ecosystem into the Optima Braille Laptop Computer

Ok, with the instructions here as well as some trying around, I did manage to get everything seated. However, I am now running into another issue.
I wrote a win11 image to an, admittedly very old, USB stick and the writing was successful.
When I power on the laptop, the fans come on and the machine is obviously working, but the screen stays entirely black. This is after jacking it into the power adapter for a while and leaving it to charge, and with the power cable inserted on powering on the device.
Everything appears to be connected and seated just fine, I mean …storage and RAM only go in one way and so does the input cover connector, so I’m not super sure what to do to debug this one. There’s no boot beeps or error noises indicating something’s wrong, and given the screen stays black even when repeatedly pressing f12 to bring up the boot options, how would you go about checking what the issue even is?

1 Like

From my experience, this is unfortunately the point when you would need someone who can see to help you. Despite the fact that UEFI firmware has advanced to the point where it could be made accessible, including any error messages that may or may not come up, no manufacturer has put in the effort to make UEFI firmware accessible beyond beeps, if such a thing is an option at all. On the Framework laptops, LED’s blink in various patterns and different colors, which you can’t see as a blind person, and there’s no audio output on the UEFI firmware, sadly.

Aside from these limitations, there are a couple things that could be causing a problem with your USB drive not booting. When you created the Windows 11 install image, did you use Microsoft’s official media creation tool, or a third party program? Others have indicated that utilizing tools such as Rufus could be problematic. The other two issues I could think of, is that your USB drive is for some reason not compatible with booting from a UEFI system, something on the SSD may be interfeering with the process of booting from the USB drive, the USB drive is for some reason not being detected by the computer, or secure boot is enabled and the drive isn’t configured for secure booting. Some of these are more unlikely than others, but all are potential possibilities.

The best way to diagnose this at this point, would be to have someone that can see help you, whether this be through a smartphone camera, or someone being physically with you and your laptop. Those are all the ideas I’ve got at this point.

Also, for those who posted the directions on the RTC battery replacement and insertion, thank you, there’s definitely more information there than the official guides provide.

1 Like

The black screen doesn’t look like the symptoms that would stem from a Windows image not written with the official Microsoft tool.

It looks more like a hardware problem, where indeed the blinking pattern of the side LED would help (on the side of the laptop where the power is connected).

But even without the blinking pattern I can try to have a wild guess. Maybe check that the RAM sticks are fully inserted (they really need to be inserted as deep as possible).

I would also try to get more info by using the BIOS screen, available by pressing F2 after powering up (what I do usually is to hammer repeatedly F2 immediately after I power on without stopping until the BIOS screen shows up).

Ah and I would also try to hammer F3, because that brings up the EFI menu. Very often, in the EFI menu you can see items not present in the F12 menu.

1 Like

Yep, Was just about to report back. It was a RAM stik not quite properly seated. Works now :slight_smile:


No. It is still ML1220.