[SOLVED] HELP! Framework 13 DIY Setup

Setting up a Framework 13 AMD DIY Edition

I just got my Framework and went with the DIY edition after watching a ton of videos online. I have little to no experience on the hardware side of things but the setup seemed straightforward so I figured I would give it a try. Close to completion (I was attaching the bezel) I noticed a cable that seemed to be both out of position and was seriously frayed. I emailed support but they said responses might be delayed to the rollout of Framework 16.

Has anyone else received a damaged DIY edition? Is there a chance the parts are reused? Will I need to take the whole thing apart and send it back in? Feel Like I hit the bad luck jackpot and just wondering how bad my situation is. Thanks.

Hey Patrick, do you mind sharing a picture so we can take a look at it?

Tried taking a new photo realized the one I took when I first noticed was pretty poor quality.

Hi @Ventus,

Welcome to the community! :smiley:

The cloth tape is designed to protect the actual cable from friction. This is done a lot in the automotive industry.

Looks like it might have gotten unwrapped a little. If you are careful with some dull tweezers you might be able to unstick it from itself (see the part that is doubled over) and wrap it a little more on the cable.

As long as everything works it should not be an issue. That appears to be the display cable? Support may be able to send you just that cable to replace. When disconnecting and reseating the cable to the display you have to be careful with it. Support is getting better however they are a small team. Congrats on your new machine and taking the DIY dive.

Thanks for the welcome! I liked the Frameworks philosophy of self repair and it seems like a reliable computer.

Makes sense about the cable. It looked mangled and out of place compared to the other side and when the Bevel would not fit properly I assumed that was the issue.

I stepped away from it yesterday but after reading your response took the keyboard back off and tried to reapply the Bevel. It looks okay open but seems just a little distressed like it is being pushed from the inside when closed. Is this normal? I am adding a photo but feel likes its harder to notice in the photo than in person.

With the Bevel on I gave it a shot booting it up. I’m a little concerned as how long I need to wait for the memory training? I gave it 10-15 minutes and then tried booting it into BIOS with nothing happening I read it can take longer? When its done memory training should it boot directly into bios?

I have two 32 GB Memory sticks bought directly from Framework so I know it might take a while.

Also should I resolve this post and make a new one if the screen never comes on?

The discord helped me fix my issues. Well mark this thread as [SOLVED]


Care to share what it ended up being?


Not sure what the issue was but it was something with the RAM. I took out and tested each stick on its own and eventually it booted up. Both sticks working now and everything seems okay with the screen and Bevel too after a few days use.

So re-seating the ram basically, ddr5 is very sensitive to having clean contacts and stuff. It’s really about time we get a replacement for sodimms, it’s a miracle they even work at all with ddr5.

1 Like