[RESOLVED] External monitor not working via USB-C and battery charge not increasing past 86% - Framework 13, Intel i5 13th Gen

Hi guys, loving the Framework so far, except for the following.

Pulled it out today and it initially worked on usb-c displaying to my monitor. I went away from my desk for 10 minutes, and external monitor was black. Not an issue as I’m aware that my ‘fix’ for this is literally just unplugging and replugging the cable.

However this did not resolve the issue, and no amount of different usb-c ports, port locations or directions of the cable have worked.

I’m running Windows 11 with all of the latest updates. I’ve got a framework 13, i5 13th gen, 3x usb-c cards, 1x usb-a card, connecting via a 4k capable usb 3.2 cable to a dell 2722qc monitor - which previously worked.

I’ve tried installing the Intel XE drivers from their webpage that are slightly newer than the Framework supplied ones however this made no difference.

At the same time, my battery stopped charging past 86%. I’ve never configured battery limits (never fiddled with the settings in the bios), so not sure why it’s doing this. I can confirm that I can unplug, and get some drain on the battery happening, but every time it’s plugged back into power the battery tops out at 86%.

I’ve not reached out to support yet, just wanting to see if the community has experienced either of these issues and has suggestions.


Issues resolved themselves after I reset the bios to defaults. Crazy, but also awesome!