[Solved] Laptop external monitor not working

I installed Ubuntu 21.04 and everything has been working great so far. The only thing is I can’t get it to recognize an external monitor I have. This is the monitor which supports video through USB C. I’ve tried with and without external power to the monitor and it always turns on saying no signal.

I’ve tried turning off secure boot but that didn’t change anything.

lsusb does list another entry when the monitor is plugged in.

What can I do to get it to recognize an external monitor?


Are you plugging the cable into the USB-C port that is between the HDMI and the other USB-C on the monitor?

Have you tried another cable?

Yeah I’ve tried every configuration of ports. I only have one USB C cable but I ordered some new ones so I’ll try them out when they get here.

You could temporarily try the USB cable that goes from the Framework to it’s charger if that isn’t the sole USB-C cable you have. The laptop should be able to power the monitor or at least supply video for a decent amount of time while unplugged.

There are quite a few USB-C cables intended for charging that are only USB 2.0. The expensive ones are Thunderbolt 3 40 Gbps.

1 Like

And then you have Apple who ships a power only cable with their MacBooks and sells people another cable at a nice markup after they’ve cried and screamed about why they can’t hook up to their dock/monitor/etc with the original cable. :stuck_out_tongue:

1 Like

I did try with the cable that came with the charger but got the same thing. The ones I have coming should be Thunderbolt 3 40 Gbps compatible. I’ll update here when they arrive.

Thanks for the responses!

1 Like

On these cheaper USB-C external monitors I’ve found the ‘auto-detect’ input switching to not always work, is there an input switch button you can press to see if it is on HDMI or USB-C?

The only options I can find are in the menu and you can only access that once it has power and video input. I used it with HDMI on my old laptop so I at least know the screen works and everything.

Can you switch it to auto or USB-C while hooked to your old laptop and/or try your USB-C module in the Framework in another slot?

Just glanced at a few Amazon reviews and it sounds like their USB-C might not work great with very recent systems.

My late model Acer laptop (ssd & usb-c) apparently from the kinda sketchy Asian to English manual indicated my trouble getting it to work w picture image was because the laptop wasn’t rated for it. But s email to customer support they said just hook-up the HDMI and USB-c & you know it works fine!

Hmm I don’t have an HDMI port for the framework so I’d really prefer to user USB C. Hopefully it’s just a cable issue

FWIW I got the “No Signal” message on a similar external display
when I tried using the USB-C cable that came with the framework power supply.

The display worked just fine when I switched to the USB-C cable that came with the monitor. It worked on Windows and also on Linux (Manjaro).

1 Like

I got the new cables in and the monitor works no problem! The one I got has 40Gbps data transfer and 100W power. So for the future I guess just make sure your cable has sufficient specs before looking into other potential issues.

Thanks so much for the responses!

1 Like

Great news @MaskedSparrow. I changed the topic title to “solved”.