[RESOLVED] [Fedora 39] [AMD] LVFS BIOS update by fwupdmgr times out

So I just got my Framework laptop 13 amd. It shipped with BIOS 3.02 so after installing Fedora 39 and running 1dnf update I decided to try to update the BIOS to 3.03 by using fwupdmgr however I am getting the following timeout error
Failed to connect to daemon: Error calling StartServiceByName for org.freedesktop.fwupd: Timeout was reached

trying to start the fwupd-refersher-service by systemctl falis as well

has anyone got this issue or am I the luck number one to get :slight_smile:

I have tried update the BIOS from arch linux as well thinking that they may have a newer version of the package but not such luck. I get the same error on arch linux so I am back in fedora to see if can get it working

I resolved this with a sudo dnf repo-sync

1 Like

Hi @Juan_A_Sanchez ,

yes do try @mikeymop suggestion, as it’s looks like a connection issue, and resyncing from repository will resolve the issue.

doing a sudo dnf reposync at the moment and will report back if it works. it looks like its pulling all 70k packages in the Fedora repos which will take a while :frowning:

in the meantime if anyone has any other things I should try as plan b if the above dose not work do share

nop that didn’t work after 5 hours and 100GB download fwupdmgr refresh still times out

If you systemctl status fwupd-refresh.service it should show a stack trace in the output.
Could you share this output?

You may also be able to trigger it with

sudo systemctl stop fwupd-refresh.service
sudo systemctl start fwupd-refresh.service

This output helped hint to me that my packages were out of sync.

So I found work around for it. After chatting to the devs of LVFS I discovered that you can set nomodeset on your grub command line partners in the grub config file which will get around the issue then you use the gnome software center to update. Using the command doesn’t seam to work to do the update so my guess is that gnome software center is passing extra arts to fwupdmgr that I don’t know about but it works in the end.

Should have posted here yesterday but forgot this :thread: existed sorry

1 Like

Thanks for the update @Juan_A_Sanchez , marking this as resolved.