[RESOLVED] Fedora 39 no user account created

Just received my Framework Laptop 13 AMD 7840U today. I added a 2tb Samsung 990 Pro M.2 SSD and Kingston Fury 64gb (2x32gb) DDR5 5600 CL40. A popular well proven combination.

The laptop came with firmware 3.03

Installed Fedora 39 workstation. After completing the install and rebooting you are prompted with the final setup screen (wifi, user name, password bla bla) then you finish with clicking on ‘Start using Fedora 39’. However, in my case no account was created and I have no access to the apps / activity menu / super key. There is also no way to shut down (only option is suspend).

I have wiped the drive and reinstalled from a new flash drive, same problem. I tried Fedora 38 and silverblue 39 same problem! Running any distro live from a flash drive works fine.

I have been a Linux user for 20 years and switched to Fedora five years ago as my primary distro. Why is my new Framework Laptop fighting me! I have searched everywhere and I can not find anyone else who has had this issue.

Please help! My new laptop is sitting here useless and has ruined my day.

Had absolutely no issue creating the user in the setup screen after the first reboot in Fedora 39 Workstation and Silverblue.

Are you sure no account got created? How do you know?

In the worst case, boot into recovery mode (bottom entry in grub, hold shift during boot if grub doesn’t show up) and then create the user there from the root account using these commands: Create A Sudo User on Fedora – TecAdmin (you should skip the last visudo command)

First off, welcome to the community, @Arthur_Power, wanted to start with that. :slight_smile:

That feels, odd. Never experienced this with any distro. Let’s back track a second. I also want to avoid being overly obvious as you are an experienced Linux user.

After another clean install of Fedora Workstation 39 and the Finish button, then manual rebooting:

  • U;pon reboot, presented with Welcome to Fedora menu/dialog.
  • Privacy, Next.
  • Third Party Repos (enable them), Next.
  • Connect Your Online Accounts (or don’t), Next.
  • About you (This is where your user is created). Next.
  • Set a password (Create your password here), Next.
  • All Done screen, click Start using Fedora Linux button.

There was no user because after a reboot the setup screen starts all over again and you can never use the OS since you do not have access to anything without an account. Going through the setup again with the same user name is accepted each time. If that user already existed it would not allow that.

You won’t offend me by any means by being overly obvious, we all over looks some things at times. :slight_smile:

Yes to the steps you listed. After ‘Start using Fedora Linux’ button I have no access to anything. A forced restart and the process starts back at the beginning. :frowning:

Interesting case, and are you able to mount your SSD from live to check if usual home user dirs are created?

Hmmm I never checked that. However, since the setup accepts the same user name again there can not be a home folder with that name.

How are you installing fedora? When you do fresh/clean install it should always accept the same name right? as previous setup is erased?


Correct it accepts the same name because I go in with a live image and use Gparted to delete all the partitions on the drive before a new clean install of Fedora.

I still think it’s worth checking out your SSD, see what user(s) are created in /home/

also can we check with sudo blkid -o list ?

cheers! :slight_smile:

I just installed Ubuntu 23.10 and it went smooth, everything works. No issues! Now why can’t this happen with Fedora!

There has to be some new bug with the anaconda installer in Fedora that has an issue with this hardware.

Myself and probably many other people have installed Fedora 39 without issue into their Framework, so you’re either doing something wrong, your installer stick is defect or you’ve found a very rare bug that only happens under weird circumstances (like in a specific time tone or with a specific user name).

1 Like

Framework AMD? Same SSD and memory? There has to be some variable.

I have made multiple flash drives and I have no issue with Fedora on my desktop.

I’m using the slower AMD variant, the WD black 770 SSD that framework sells and 2*16 crucial memory, but I don’t think that this is a hardware issue. It would help if you could boot from from rescue mode (or from a live media and chroot) after a failed installation and check the system logs (journalctl) and if the user is actually present.

Have you done any specific partitioning or other settings? Have you switched gdm to x11?

Just checked with a live image and the home directly is empty as I suspected.

1 Like

I am still fighting with this thing. I tried installing OpenSuse Tumbleweed. Install went smooth and it works fine. OpenSuse is a RPM based distro and has the option of Gnome 45 so I thought maybe I can live with this. However, there are to many goofy and outdated aspects of Suse. The biggest issue is scaling which might also be an issue with Fedora. I can not enable scaling in the live version to test. In Suse the text in some apps like Chrome was a blurry mess. Is scaling of like 150% working in Fedora with wayland?

Yes, but in Gnome the option is experimental and old XWayland apps will be blurry. KDE is probably working better there, but I don’t have much experience with it. Chrome has an experimental option to enable Wayland and proper scaling. Or just use Firefox or Gnome Web, which both scale fine.

I personally use 100% scaling with 120% font size enabled in the accessibility settings. That looks better and is not blurry.

I forgot about the flag in Chrome for Wayland support. I tried that and it does seem to work fine. I am coming from a Huawei matebook pro (Intel 8th gen) with the same 3:2 ratio display and same size 13.5". However the resolution was 3000 x 2000 so a setting of 200% worked nicely. Maybe Framework will offer a premium display in the future with this same resolution? I do love the matte finish of the Framework display the super glossy display on the matebook pro was killing me. It was like using a mirror!

I still can not install Fedora 39. The gnome setup fails to successfully create a user account. I even tried the network installer since that enables you to create a user account in anaconda. However, when I reboot I am still presented with the Gnome setup screen to create an account. Still no user account is created.

So I tried installing Red Hat enterprise desktop trial. No problems at all! Not sure it’s worth paying $180 a year though. Of course a lot of the software is a bit dated.

No idea, is there any weird configuration going on? Are you using a custom partitioning setup for the home partition that could make it go vanish? Are you using weird characters in your user name?

I would try to check the system journal for error messages, as I wrote. (probably in recovery mode, as you have no working users). Boot into recovery mode and launch journalctl and scroll near the end to find messages around when you tried to create the user. While in recovery mode you could also try creating that user manually if you follow the instructions I linked you above.

Everything was a default install.

I still don’t know the cause but I stumbled upon a solution. I did anther net install and this time I choose ‘Basic Desktop’ and added just one option ‘Gnome’. Everything is setup and configured in Anaconda this way. No Gnome setup screen on first boot just a logon screen showing my user account. :slight_smile:

Everything works. The only issue is Thunderbird is not starting in Wayland mode for some reason. Firefox does however. I am still looking for a fix.

1 Like