[RESOLVED] Fedora39: dgpu not utilized/detected

OS: Fedora Linux 39 (Workstation Edition) x86_64
Host: Laptop 16 (AMD Ryzen 7040 Series)
Kernel: 6.8.4-200.fc39.x86_64
CPU: AMD Ryzen 9 7940HS w/ Radeon 780M Graphics (16) @ 5.423GHz
GPU: AMD ATI Radeon RX 7700S/7600/7600S/7600M XT/PRO W7600

Since getting my laptop I have had many problems with my graphics on linux(none of which are present on windows).
I think that my problems lie with my graphics drivers somehow but I know they are included in the kernel/fedora by default.
when I try to run games, blender, or any benchmark I get VERY poor performance even with DRI_PRIME=1 option set.
I tried running glmark2 with DRI_PRIME set and the framework dgpu utility said it was being used but performance was still much less than expected.
Things get even more confusing when I run vulkaninfo | grep "GPU[0123]" -A 10 because it only displays llvmpipe and doesn’t even include my igpu.
this is all I get out of that command:

	apiVersion        = 1.3.267 (4206859)
	driverVersion     = 0.0.1 (1)
	vendorID          = 0x10005
	deviceID          = 0x0000
	deviceType        = PHYSICAL_DEVICE_TYPE_CPU
	deviceName        = llvmpipe (LLVM 17.0.6, 256 bits)
	pipelineCacheUUID = 32332e33-2e36-6161-6161-616161616161

Why isn’t this displaying my other gpu devices?

also worth noting that when I run nvtop I get ‘No GPU to monitor.’

Any info would be great! thanks!

This is just a stab in the dark (I don’t have my FW16 yet), but did you enable third party repositories mentioned in the guide?

Can you post the output of the following from terminal:

# lspci | grep 7700

This sounds like the amdgpu kernel module isn’t getting loaded for some reason. Look at your journal for related information. Did you by chance put nomodeset on the kernel command line?


That was exactly my problem!
I edited my kernel parameters and now It’s working fine.
I have no idea how that got in there.
Thank you Mr Mario!


Mario saved the day, thank you! Marking resolved.