[SOLVED] Low graphics performance on Framework 13 7040 AMD

Hi everyone,

I am using a Framework 13 AMD Ryzen 7040 version with these stats:
OS: fedora linux 39 (Workstation Edition)
Kernel: 6.5.6 (kernels are updated)
DE: gnome 45.2
CPU: AMD Ryzen 5 7640 U w/Radeon 760m
GPU: AMD ATI c1:00.0 Phoenix1

I am using Wayland, but also tried X11, the issue remains. I have really poor graphics performance over the Firefox browser in Youtube and browsergames like Geoguessr. There are graphics glitches as well.
I switched to Chrome and the graphics glitches went away. The poor performance remains. I have my BIOS on UMA_game_optimized, I have used the "GRUB_CMDLINE_LINUX_DEFAULT=“quiet amdgpu.sg_display=0” command, but the problem remains. When testing, the CPU and GPU are never on their limit, still the performance doesnt improve.

Do you know what could be causing that issue? Please kindly reply :smile:

1 Like

Is this issue in play confusing the situation further? 6.5.6 is quite old.

1 Like

Welcome to the community!

Two things that stand out:

  • BIOS version?

  • As @dimitris correctly points out, you may need to run through the steps outlined in their link.

What I’d like figure out is how are people arriving at this state. Either way, adding this to the Fedora 39 docs today as it is happening enough folks need to be aware of how to fix it.

Hi there,

I am happy to be here!

My BIOS version is 3.03

updating my kernel solved the problem, thanks for your help :smiley:

1 Like

Awesome, delighted to hear this! Marking resolved.