[RESOLVED] Fingerprint not recognized

I just got my Framework 13 Intel and installed Fedora today! I’ve tried registering a fingerprint but got that it’s not recognized. Followed the guide, with fwupdtool and wget for the fedora cab files, and downgraded as requested but when i tried to do the update after, this is what I got:

melaniecarr@fedora:~$  sudo fwupdtool install --allow-reinstall --allow-older goodix-moc-609c-v01000330.cab
Loading…                 [*****                                  ]19:29:27.297 FuEngine             failed to add device usb:03:00:09: failed to get firmware version: failed to reply: device was disconnected
Decompressing…           [ -                                     ]
No supported devices found

Can someone help me figure out what my next steps should be to get it to be recognized?

Loading…                 [************************************** ]
Framework Laptop (13th Gen Intel Core)
├─UEFI dbx:
│ │   Device ID:          362301da643102b9f38477387e2193e57abaa590
│ │   Previous version:   33
│ │   Update State:       Success
│ │   Last modified:      2023-12-18 17:01
│ │   GUID:               c6682ade-b5ec-57c4-b687-676351208742
│ │   Device Flags:       • Internal device
│ │                       • Updatable
│ │                       • Supported on remote server
│ │                       • Needs a reboot after installation
│ │                       • Device is usable for the duration of the update
│ │                       • Only version upgrades are allowed
│ │                       • Signed Payload
│ │ 
│ └─Secure Boot dbx Configuration Update:
│       New version:      371
│       Remote ID:        lvfs
│       Release ID:       35287
│       Summary:          UEFI Secure Boot Forbidden Signature Database
│       Variant:          x64
│       License:          Proprietary
│       Size:             21.2 kB
│       Created:          2023-05-09
│       Urgency:          High
│       Tested by DMC Group:
│         Tested:         2023-07-11
│         Distribution:   fedora 38 (workstation)
│         Old version:    211
│         Version[fwupd]: 1.9.2
│       Tested by Jabra:
│         Tested:         2023-07-03
│         Distribution:   ubuntu 22.04
│         Old version:    220
│         Version[fwupd]: 1.9.3
│       Vendor:           Linux Foundation
│       Duration:         1 second
│       Release Flags:    • Trusted metadata
│       Description:      
│       Insecure versions of the Microsoft Windows boot manager affected by Black Lotus were added to the list of forbidden signatures due to a discovered security problem.This updates the dbx to the latest release from Microsoft.
│       Before installing the update, fwupd will check for any affected executables in the ESP and will refuse to update if it finds any boot binaries signed with any of the forbidden signatures.Applying this update may also cause some Windows install media to not start correctly.
│       Issue:            CVE-2022-21894
│       Checksum:         fc3feb015df2710fcfa07583d31b5975ee398357016699cfff067f422ab91e13
└─Fingerprint Sensor:
  │   Device ID:          4295296d98b3ba38c72f6baa33d24f03a1d428f6
  │   Previous version:   01000320
  │   Update State:       Failed
  │   Update Error:       failed to write: failed to reply: transfer timed out
  │   Last modified:      2023-12-18 19:28
  │   GUID:               1e8c8470-a49c-571a-82fd-19c9fa32b8c3
  │   Device Flags:       • Device can recover flash failures
  │                       • Updatable
  │                       • Signed Payload
  └─(null) Update:
        New version:      01000330
        License:          Unknown
        The vendor did not supply any release notes.

I recalled seeing something about secure boot and updating the fingerprint reader. You might try turning off secure boot, then updating the firmware for the fingerprint reader. More here: [RESOLVED] Issues following fingerprint reader and BIOS update guides for AMD - #9 by Juan_A_Sanchez - I know that is for AMD, not sure if it holds for Intel as well, but might be worth a try.

You may need to follow the last bit of troubleshooting on this help page (it’s what I needed for my amd batch 7). It sounds like your fingerprint sensor just isn’t detected. I think because fwupd is just too old.

Scroll down to the section titled “TROUBLESHOOTING fwupd is older than 1.8.8”

1 Like

@cmstew @lbkNhubert thanks! I ended up doing a reboot and retrying, and it worked!


Glad this worked out :slight_smile: , labeling as resolved.