[RESOLVED]Fingerprints lost after suspend or reboot - Fedora 39

Hi all,

I followed a guide to enable disk encryption together with setting up snapper for snapshots and during the process a very basic installation of Fedora 39 is installed for you to then carry on and install what you want.

I’ve followed a couple of guides here and used the appimage tool to clear previously registered fingerprints and I can get the fingerprint reader working and registering fingerprints but for some reason all the settings get lost following a reboot or waking up from sleep.

The fingerprint app within gnome settings shows as disabled and no fingerprints registered, however I definitely had it working about 30 minutes before.

This worked perfectly with a regular install from a LiveUSB so I’m either definitely missing a setting somewhere or a package isn’t installed following this minimal install.

Is anyone able to help diagnose this one?


All please ignore this.

I’ve realised that its due to the snapper rollback - /var/lib/fprint where the fingerprints are stored isn’t excluded when rolling back snapshots and therefore the contents is lost each time.

I’m trying to figure out what I need to do to exclude this - nothing wrong with the install or a missing service etc, its down to how the snapshots are working.


Welcome to the community!

No worries, glad you found the issue.

Likely going to mean adding something along the lines of FILTERS="exclude /var/lib/fprint" in /etc/snapper/configs/blah

In any event, marking the thread as solved. :slight_smile: