[RESOLVED] Flickering white video glitches when trying to play Baldur's Gate 3

video recording of the problem here:

please help!

I am using a brand new framework 13 laptop (received in Nov 2023) with the following specs:

Hardware information:
Model: Framework Laptop 13 AMD Ryzen 7040Series
Processor: AMD Ryzen 5 7640U with Radeon 760M Graphics x 12
Memory: 32GB
Disk Capacity: 1TB

Software information:
Firmware Version: 3.03
OS Name: Fedora Linux 39 (Workstation Edition)
OS Type: 64-bit
GNOME Version: 45.2
Windowing System: Wayland
Kernel Version: Linux 6.6.3-200.fc39.x86_64

Description of glitch: flickering white artifacts, sometimes obeying the shape of graphics elements in the game, other times filling the entire screen. They will disappear if I click the + or - volume buttons, or the + or - screen brightness buttons, or if I enter the “activities overview.” You can see the volume and screen brightness overlays pop up at the bottom of the screen, and suddenly the game is displaying normally. This shows me that the video is probably rendering fine at some level, but is getting messed up in the final display.

History of my own attempts to troubleshoot:
Before BG3 patch 5 on November 30: Installed fedora 39, without running “sudo dnf update” in terminal to ensure all packages and drivers are up to date. The game was working. I suspect patch 5 may have had something to do with the video glitches.

Since I started having this problem: I tried a clean install of fedora 39, without running “sudo dnf update” to ensure all drivers and packages are up to date, continued to have the same glitches.

Then I did another clean install of Fedora 39, ran “sudo dnf update” in terminal to ensure all drivers and packages are up to date. Installed steam and BG3. Still having the same glitches.

Attempting to play using “vulkan” instead of “directX 11” causes pretty immediate crash.

I also tried running the game with different desktop environments, I tried all 4 options available: GNOME, GNOME Classic, GNOME Classic on Xorg, and GNOME on Xorg. All four have the same problem. Though interestingly, the first time I used GNOME Classic on Xorg it ran just fine until I closed the game app, after which the entire screen went white and I had to hard reset my laptop.

Possibly Known issue ;


and if you game a lot also add:


To disable scatter gather which has been enabled since 6.2 series and seems broken until 6.7rc series.

I have no issues running BG3 with wayland under Plasma with Proton-GE 8-25 on fc39 (albeit with custom kernel). It has some known bugs with input handling with the stable steam client so you might want to switch to beta channel (that seems to resolve it not picking up second controller for me) tho so you millage may vary


How is your performance?
I have not bought my framework to play anything than factorio if even that but i tried Baldurs Gate and it ran…playable if my life depends on it, in 720P and low everything. BUT, i am on Kernel 6.2 and did nothing to ensure that the vega stuff is actually put to efficient use. Regardless, and some point KDE Neon will update their stuff and i am curious what might be possible

Well the AMD framework 13 is a slightly better steam deck… So pretty much use protondb as a reference, and plenty of people are happily using it to play a range of things I wouldn’t.

I tend to use Civ6 as my benchmark because I know how it performs. Bg3 isn’t a game I actually enjoy, but it has couch play. And I loaded it on my HTPC box which has a 6800xt at the same time as testing the fw13 so it was a curiosity moment to test some bits.

Eck yeah get a newer kernel :slight_smile:


woaah nice, this fixed my problem with screenshoting under wayland/sway

scatter gather is still broken in 6.7rc4 actually. I just had it trigger after 3 hours of HDMI output from a presentation and then disconnect/sleep and resume 30mins later.

So yeah running with amdgpu.graphics.sg=0 still required.

1 Like

I can second this, reproduces about half of the time after a long suspend.

This fixed my problem! (mostly) I also tried disabling scatter gather as jwp suggested, which seemed to create some instability, so I reversed it.

The remaining problem, which I can mostly avoid: now if I’m gaming for a while (an hour or so in) and I accidentally hit the super key, which opens the Activities Overview, the exact same glitch happens and I have to force reset the computer – sometimes it’s not possible to exit the game, and even if I do, the video glitch is still happening.

Another random way the glitch triggered again is when a low battery notification popped up, I plugged the charger into the port, and the exact same flashing white glitches showed up.

Since this works well enough for me to play for hours at a time, I consider my issue mostly addressed. Thank you jwp!

1 Like

you need to do scatter gather disable ; and also add the latest amd-drm ipu-staging linux-firmware to get the currently most stable set of things on Phoenix. Scatter gather will cause some performance/PM degradation but will solve suspend and glitching for the most part, which is IMO a worthwhile tradeoff. Considering that it’s disabled by default in any kernel pre 6.3 anyway ; so anyone running the ubuntu LTS, Arch and several other distros shipping ancient kernels won’t have it turned on anyway.

1 Like

Marking resolved, thanks for the help @jwp!