[RESOLVED] Framework AMD Fingerprint reader not working

Hi there,

I just got my AMD Framework 13 (7840u) and installed Fedora 39 Beta on it per the instructions. Most things are running great, but the fingerprint reader doesn’t seem to work. I get “failed to claim fingerprint device Goodix MOC Fingerprint” in the GNOME fingerprint dialog. Could this be the same issue as the Intel 13th Gen models?

I did not install Windows on this device.

EDIT: solved, follow this guide https://github.com/FrameworkComputer/linux-docs/blob/main/13th-gen-fingerprint-reader-firmware.md

1 Like

Have you tried wiping it? It may be a problem of QC not wiping it after testing. idk just a shot in the dark.

Hi, I found this by clicking through the forum in the main topic, the one that you want the most is probably the last one.

Latest Framework Laptop 13/Linux topics - Framework Community

[Fedora 39] Official Fedora 39 Thread - Framework Laptop 13 / Linux - Framework Community

Fedora 39 Installation on the Framework Laptop 13 - Framework Guides

linux-docs/13th-gen-fingerprint-reader-firmware.md at main · FrameworkComputer/linux-docs · GitHub

1 Like

Did you get the firmware update?


Note: The firmware update is for the fingerprint reader…not the laptop.

On the 13th gen Intel side of the camp, the firmware [beta] update didn’t seem particularly smooth:

1 Like

I spent hours on this today. I have installed Ubuntu fedora and windows lol.

The commands for lvfs or manual install didn’t work for me. Fwupdmgr just hang.

I had to download a windows iso. Install it, and install the framework windows 11 driver bundle. THEN fedora / Ubuntu work because the fingerprint reader gets downgraded to a correct release.

You don’t have to pay for windows to do this, just takes a bit of time. Hope this helps


Following these instructions fixed it. Thanks all.


Yes, this is the guide provided in all our documentation. This is correct IF AMD or Intel 13th gen. This is not needed on the other configurations as that was a different firmware release.

1 Like

im having the same problem with fwupdmgr hanging. still wont work

What Kernel are you using. I found that switching to 6.1.0-1023-oem allowed fwupd to load correclty. After that I was able to update the firmware of the finger print reader.

i installed windows and updated the fingerprint reader that way also. nothing that was suggested to me fixed my issue.

I spent a day and finally managed to update the fingerprint scanner only using Linux.

I believe the hanging issue with the fwupd* is caused by the amdgpu issue which I hope is getting fixed in the bios 3.03?

In the meantime, if you boot Ubuntu 22.04.3 in the recovery mode the gpu doesn’t get in your way and you can update the firmware. I forgot which of the fwupd* commands I ran to see it getting stuck at the gpu, but that gave me an idea to try the recovery mode.

I think to update the bios to 3.03 eventually, we need to boot in the recovery mode as well.

1 Like

Sh_Ra is correct. The hanging issue with fwupd is caused by the gpu issue. The plugin causing the problem is synaptics_mst.

You can edit /etc/fwupd/fwupd.conf and add synaptics_mst to the DisabledPlugins section to get fwupd working.

Alternatively, when updating the fingerprint sensor firmware, you can use “–plugins goodixmoc” on the install command to allow only the Goodix plugin to run.

sudo fwupdtool install --plugins goodixmoc --allow-reinstall --allow-older goodix-moc-609c-v01000330.cab


All, please make sure to update to the latest BIOS beta for AMD 7040 series. AMD Ryzen 7040 Series BIOS 3.03 and Driver Bundle Beta

1 Like

Can confirm: updating to 3.03 BIOS and running the manual .cab install again worked. No errors and sensor is working perfectly now in Fedora!

1 Like

I apologize opening this thread again, but I tried this guide, but I get this result (Fresh Fedora 39 install, laptop 13 AMD):

Loading… [******** ]01:42:51.717 FuEngine failed to add device /sys/devices/pci0000:00/0000:00:08.1/0000:c1:00.0: ioctl error: Bad address [14]
Decompressing… [ - ]
generic GUID requires a CHID, child, parent or sibling requirement

If it can help, my BIOS version is 3.03, fwupd that i’m running is 1.9.9, and I do get the result " [USB\VID_27C6&PID_609C] Plugin = goodixmoc " when I try to check the quirks.

Any feedback is appreciated, thank you in advance.

Someone else referenced the root cause for this GUID error here, can’t find that post at the moment found it. TLDR is still:

  • The cab file needs some more specific metadata as of fwupd 1.9.7, and IIRC it will have to have that meta to be made available on LVFS.

  • You should be able to temporarily downgrade fwupd to 1.9.5 (version at the time of F39’s release):

    $ sudo dnf --disablerepo updates distro-sync fwupd*
    Last metadata expiration check: 0:34:11 ago on Fri 24 Nov 2023 07:58:45 PM PST.
    Dependencies resolved.
     Package                                                             Architecture                                Version                                             Repository                                   Size
     fwupd                                                               x86_64                                      1.9.5-2.fc39                                        fedora                                      2.0 M
     fwupd-plugin-flashrom                                               x86_64                                      1.9.5-2.fc39                                        fedora                                       24 k
     fwupd-plugin-modem-manager                                          x86_64                                      1.9.5-2.fc39                                        fedora                                       56 k
     fwupd-plugin-uefi-capsule-data                                      x86_64                                      1.9.5-2.fc39                                        fedora                                      2.0 M
    Transaction Summary
    Downgrade  4 Packages
    Total download size: 4.0 M
    Is this ok [y/N]:

    Remember to sudo dnf update fwupd* after you’ve updated the FP reader.


Thanks a lot for pointing me in the right direction. I was able to downgrade to 1.9.5 and fwupdtool went further and started to write. However, it failed at the end. Funny enough though, I am able to add fingerprints and all works. This relevant result when sudo fwupdtool get-history:

Fingerprint Sensor:
│ Device ID: 23ec719b6aabc2d2dac5176c232f0da7a21881b0
│ Previous version: 01000320
│ Update State: Failed
│ Update Error: failed to write: failed to reply: transfer timed out
│ Last modified: 2023-11-25 13:24
│ GUID: 1e8c8470-a49c-571a-82fd-19c9fa32b8c3
│ Device Flags: • Device can recover flash failures
│ • Updatable
│ • Signed Payload

└─(null) Update:
New version: 01000330
License: Unknown
The vendor did not supply any release notes.

In any way, it now works so I’ll leave it alone for now :man_shrugging:

1 Like

Appreciate you sharing this. I’ve also updated the guide to reflect the changes outlined.

We will be re-visting the LVFS method again when I can re-test it. Previous attempts had a lot of folks unable to update, so I need to revisit it carefully before I switch the guide back to that.

1 Like

And we’re ready - please follow the direction to the letter, I tested this myself with two brand new input kits and used the exact steps outlined here. Please read the entire first section of this before trying.


I’ll note that I had the same issue of the failed to claim fingerprint device Goodix MOC Fingerprint error in GNOME settings, and followed the associated guide the OP mentioned in their edit, but still was unable to get things to work. As a last ditch effort I tried using the fprint-clear AppImage to try and start fresh, and that sort of did the trick.

I’ve noticed instability when more than 3 fingerprints are enrolled - if I try to scan an enrolled finger (on the lockscreen) when more than 3 are enrolled, it’ll immediately say “Fingerprint not recognized” in the text beneath the login box. It seems to be stable after only enrolling 3 fingerprints, and now that I think of it, this issue only appeared after I enrolled another fingerprint on a whim yesterday.

Has anyone else experienced this issue? Is this reproducible for others? If so, I’d be happy to make this a separate thread if it’s unrelated from this issue.

1 Like