[RESOLVED] Kernel 6.4 hang at boot TPM Bug Confirmed

Okay, on Fedora 38 on 12th Gen mainboards.

This workaround confirmed working for me on multiple 12th gen boards:

  • Boot into previous kernel from grub menu.
  • Terminal, run sudo grubby --update-kernel=ALL --args="tpm_tis.interrupts=0"
  • Reboot into 6.4.4 and it hangs for a split second, then arrives at the expected screen successfully.
  • This was done without external displays attached or anything other than power to the laptop.

Anyone who is experiencing this after running the above command and rebooting, please list the following:

  • 11th, 12th or 13th gen?
  • On GNOME, about, what CPU is listed?
1 Like

That worked for me @Matt_Hartley. The only difference this time was that I noted what you wrote and disconnected my external display before rebooting. Perhaps coincidence, perhaps not.

1 Like

Running into this on a new install today. (Framework 13, Intel)
Installed Fedora 38, everything is good (kernel 6.2.9)
Did a full dnf update, which installed kernel 6.4.4
Hangs with black screen on boot, if I select the newer kernel.
Still boots fine on 6.2.9

1 Like

ubuntu mainline (https://kernel.ubuntu.com/~kernel-ppa/mainline/)
is good starting with 6.4.6

6.4.0-6.4.3 hangs
6.4.4 and 6.4.5 don’t exist (failed builds)
6.4.6 runs

(with TPM available in bios and without tpm_tis.interrupts=0)


Awesome! Appreciate the assist! :slight_smile:

I should have added that I am using Fedora 38, gnome 44.3 as well, 12th Gen unit… Command I used: sudo grubby --args="tpm_tis.interrupts=0" --update-kernel DEFAULT

1 Like


After a software update from Fedora, my Framework 12th gen got stuck at the “Framework” splash screen during boot.

By holding down the power button to turn off, then pressing it again to turn on, it gave me the option to boot using an earlier version of the kernel (6.3.something). Once logged in, I used terminal command from this thread sudo grubby --args="tpm_tis.interrupts=0" --update-kernel DEFAULT and restarted. My laptop now boots into kernel version 6.4.4-200.fc38.x86_64 just fine.

Thank you! This is why I love my Framework. If there’s a problem with Linux I know I’ll be able to get help with it really quickly.


Framework 13, 13th Gen, Fedora 38, XFCE
Running the below worked:

sudo grubby --args="tpm_tis.interrupts=0" --update-kernel=/boot/vmlinuz-6.4.4-200.fc38.x86_64


I’ve just installed linux-image-6.4.0-1-amd64 from Debian Testing on my first generation FrameWork 13 DIY (on an up to date testing system). Unfortunately the boot attempt is running into Kernel Panic. I’m able to boot from grub alternatives 6.3.0-2-amd64. Any idea if something is broken with kernel 6.4.0?

Kind regards, Andreass.

Hi Andreas,

I’m just answering from a running linux-image-6.4.0-1-amd64 on first gen FrameWork 13 DIY. So it did not crash here.
How far has the boot up come on your laptop? Could you see some of the last log messages?

Best regards

PS: Maybe I was successful, because I’m using refind instead of grub and dracut to generate initrds.

The issue is fixed in kernel 6.4.4, so get that version if you want to use Kernel 6.4

Debian version numbers may be a bit misleading. linux-image-6.4.0-1-amd64 actually contains Linux kernel 6.4.4.

I’m not keen on any kernel version - just need a running laptop. Removing the actual kernel package and falling back to the previous one is a perfectly valid solution for me. But I wanted to report the issue.
Regarding the question: I’m just getting the first three or for messages on screen before grub is starting. I also have to pick from grub alternatives when trying to hibernate my now running 6.3.0-2.
Kind regards, Andreas.

See here, likely the same issue:

Doing some post merging here, so if you see links to this thread here, it’s fine.

Folks, we have determined the following:

  • Fedora 38 we can add the needed parameter: sudo grubby --args="tpm_tis.interrupts=0" --update-kernel DEFAULT
    has worked over and over internally.
  • Ubuntu 22.04 users can simply skip this entirely and get to with 6.4.6 (thanks @Brian_White)
    sudo add-apt-repository ppa:cappelikan/ppa -y && sudo apt update && sudo apt install mainline -y && sudo mainline --install-latest --yes

With both examples, simply rebooting afterward will get you to a good state.


I just ran a dnf upgrade this morning which took me from kernel 6.3.8 to 6.4.4 on Fedora 38.

A reboot resulted in a black screen, which required a hard power off. On rebooting into 6.3.8, I found these threads.

My next step will be to add the tpm_tis.interrupts parameter to see if that resolves the 6.4.4 issue, but just running with 6.4.4 does not seem to be a fix.

If you don’t want to wait, 6.4.6 is already available in testing (37, 38), sudo dnf --enablerepo updates-testing --refresh update kernel* should get it.


It looks like 6.4.6 is working on Fedora 38 on my 13th gen.
If you go into Software Center->Updates, click on the 3 bars and select Software Repositories you can add the Fedora 38 - x86_64 - Test Updates repo. After that, you can run a dnf update or check for updates in the Software Center.
After downloading the updates, It requires a restart, and will again hang at boot. If you power off and then reboot into the earlier kernel version you were using, It should finish the update.
I don’t typically run test updates, so I disabled the repo after the update, and would recommend doing so too if you don’t want early software versions.

1 Like

This is the way. :slight_smile:

I’ve disabled TPM through the BIOS until the update hits stable. This is not the ideal solution, but it made all the problems disappear.