[Fedora 38 thread] Fedora 38 on the Framework Laptop

@a_framework_owner Thank you for the feedback.

Let’s wrap this up here as to keep this very specific, topical thread on topic and avoid making this a lengthy back and forth. Thank you


Just got a new 13th get Framework 13. FWIW, on Fedora 38 I had to disable secure boot for sleep to function. This is with full disk encryption. TLP with default config.

1 Like

This is usually the first thing I do in general. Was this for a dual-boot setup?

@Matt_Hartley No, just Fedora 38, no other OS’s installed.

Hello, everyone. I took the Linux dive last year with my purchase of a DIY Framework 13 12th Gen laptop, on which I installed Fedora Linix. I’ve been loving it. Every day I check for updates in Gnome Software and run them. So, I have been using Fedora 38 since it became available. Today, however, after running the updates, my laptop now take a very long time to boot and/or restart. I’m talking go take a shower, make a pot of coffee, and vacuum the living room long. Seriously, the laptop sits on the “Framework” welcome image for a good 20 minutes or longer before it finally goes to the user login button. Has anyone else encountered this after installing today’s Fedora 38 updates?

Have a look at:

With a workaround for Fedora:


Sounds like the TPM bug, please see the above links.

Thanks, @Matt_Hartley and @next_to_utter_chaos for the speedy replies. I’m tied up for the rest of the evening, but I’ll implement in the morning and let you know how it goes. I greatly appreciate your advice!

1 Like

The suggested remedy worked perfectly. Thanks very much!


The above solution worked perfectly for me too!

I love how the Framework only needs a single press of the ESC key to access the grub menu when the FrameWork logo first comes up.

I prefer single press to constantly needing to press a key at boot or even worse when you need to hold a key.

Thanks heaps all.

Will we get a different guide like this (https://github.com/FrameworkComputer/linux-docs/blob/main/Fedora38-13thGen.md) for the AMD version once it gets released? Or does it all apply the same (after all it’s just tweaking the SSD and brightness keys).

Yep, we will have a specific guide for AMD Framework 13 here in the near future.


Is only the Workstation edition supported (aka only GNOME) or are the spins also supported?

We have folks in the community running all sorts of spins and related. And we encourage you to use what works best for you. However, it’s when it comes to troubleshooting in a ticket that we ask that the point of failure is tested on a supported distro (GNOME/Fedora for example) as we test against it.

So if something was having issues in, KDE for example, but didn’t have those experiences in GNOME, we feel confident that it’s not hardware. We’d then try to point you in a good direction for the support with the KDE issue, but recommend GNOME as it is rock solid.

That said, everything in Fedora (for the most part) is pretty great.


I’ve been on popos with my framework 11th gen for a while now, but I wanted to try fedora since it seems popos is no longer officially supported by framework. I installed fedora 38 fresh to an external drive just to try it out, and followed this guide: Optimizing Fedora Battery Life

I’m losing about 3-4% battery per hour on sleep, which as I recall is similar to what I get in popos. The difference is that I have hibernate enabled on popos, so I don’t notice it as much. Is it normal to lose battery this quickly while the laptop is asleep in fedora? It doesn’t seem like hibernate is really an option with fedora, which makes me hesitant to switch.

I have the same problem. I have the feeling it came with some update. Hopefully it also goes away with an update… Next major release will be in october. If this doesn’t fix it, I switch to some other distro… sad… was quite happy with fedora…

That’s certainly not what I’m seeing with Fedora on an 11th gen with 16Gb of memory. On s2idle, I’m seeing 0.32W-0.8W depending on what expansion cards are plugged in. So that’s more in the 0.5-1.5% range. This is in line with what I have seen reported by other people too.

If you have expansion cards plugged in, you might try what you get when you remove them. For me, ‘nvme.noacpi=1’ made by far the biggest difference in improving s2idle power usage (to the point of not being significantly different from deep, which takes much more time to wake up from).

1 Like

Hibernate is disabled when Kernel Lockdown is enabled and many distros are moving away from hibernate. I feel your pain since I prefer hibernate to sleep but hibernate seems to be dying. Fedora does not support hibernate and will not support hibernate.

I found the following Fedora Bugzilla ticket to manage Framework-related issues in Fedora. It seems that the ticket is the top-level ticket. You can see the issue tickets on the item Depends On. I updated the first comment on this thread.

I appreciate the people working at the Fedora project!

(Framework) - Fedora Framework support tracker bug

Right now there is one issue ticket.
[abrt] __schedule: WARNING: CPU: 0 PID: 18 at kernel/rcu/tree_plugin.h:318 rcu_note_context_switch+0x4f8/0x6b0

I think other Linux distros can apply the upstream patch for their packages to fix the issues later when people see the issues.

1 Like