[RESOLVED] Linux boot error. Cros-usbpd-charger cros-usbpd-charger:2.auto: Unexpected number o

As of Friday, when I try to boot my FW13, I always get one of these two errors. It will then sit there with just this screen forever. The only thing which makes a difference is me pressing the power button which powers it off instantly. I’m currently trying to drain its battery to see if starting it from dead fixes it.

Google is only pointing me to one other page on the FW forum, but that person seems to be able to enter key-presses, so I can’t follow that.

I’d rather not flash a new instance of the OS onto it since I have a few things I’m not sure if are backed up. But, if that’s the only solution I can still do it.

Anyone see this/have solutions?

I am going to go on a limb and suggest you reed this topic and let us know if it matches up. [RESOLVED] Kernel 6.4 hang at boot TPM Bug Confirmed

Looks like you ar elikely running linux and this looks like it is after the grub screen. If you follow the solutions in the linked thread I think most if not all of what you are seeing will go away, however if it does not try reseating all your expansion cards.

1 Like

Welcome to the forum.
If the thread Nadb posted doesn’t help you, we would need more information to try to help.
The linux distro and version you’re running.
Which generation Framework 13 you have.

You could create a Linux flash drive to boot into, then see if you can access your files.

I’d echo everything both nadb and MJ1 have suggested.

Start there, if it continues you can open a support ticket for additional assistance.

1 Like

Hi, thank you all very much for responding. I tried all of the things I can follow from that thread (which is only to do TPM hidden, I don’t know how to change kernel parameters without hitting my OS).

I am running Linux, Ubuntu 22.04 (Don’t know the precise version until I can boot properly once).

The sequence that occurs is:
Framework logo
Error message: “cros-usbpd-charger cros-usbpd-charger:2.auto: Unexpected number of charge port count”
Framework logo
The error I posted before (same thing but it cuts off the end of ‘of’ and everything after that).
Then it hangs here.

I can’t boot off of a USB device for a little bit but I will soon.

Unseating all of the expansion cards did change the error message, it shortened it. Here are two more photos of error messages (I found another display screen that I should’ve already probably known about)

The line after ‘Unexpected number o’ has only occurred once, it doesn’t show up each time after that.

Alternate display:

EDIT: Realized I didn’t say specifics about my framework. 12th Gen, running the middle strength of the three 12th gen processors, 16gb ram, and I think that’s pretty much everything relevant? Connected expansion cards are 1x USB-C, 1x USB-(normal size), 1x HDMI, 1x Ethernet port. But those might not matter since I’ve taken them all out.

That second screen shot will only occur once a kernel is in the process of booting your OS. There should be a grub screen where you can pick the kernel or a splash screen with the Ubuntu logo. Basically right after the framework screen hit the esc button until kernel selection comes up and then press e. This will allow you to add a kernel parameter. Add the one detailed in the other thread after the word quiet. Hit ctrl+x and let it boot.

If you cannot get to grub and select a kernel, you will want to boot into a live usb and use whatever prcedure Ubuntu recommends to essentially chroot into your actual sysroot and edit your /etc/default/grub to allow it to become visible, it may have a zero second delay but most distros default to 3-5 seconds so you have time to make edits if needed.

If you are seeing the gdm issue hit ctrl+alt+f4 to switch to console, login and dig around your journalctl and logs to see what is going on. FInd out your Ubuntu version, the kernel being run, and any graphics drivers being used.

Also what BIOS are you on?


The cros…usbpd error is, unfortunately, a red herring. It just happens to be one of the drivers that doesn’t respect the quiet kernel argument that suppresses all the other output.

If you can get to the command line editor @nadb mentioned, you can also try to remove the words quiet and splash to see if the kernel will cough up more useful information.

1 Like

Misread the responses, thought I needed to bootable drive to keep troubleshooting (but I was wrong). I can get into that kernel menu, swap out ‘quiet splash’ with ‘detailed’, and then boot. When I do, a long set of loading message load, I can quickly try to read them, but all of them are succeeding. Then the screen goes black, and it shows us that same screen as before where it’s talking about GNOME display manager not booting.

And my bios version is 3.05.

Any advice?

If it was me, personally, I’d use a live USB and an another drive to make sure the data is backed up.

I’d then try a fresh install. Yes, we could drop down to a shell and tinker around. But in my own head, I’d want to troubleshoot this on a clean install and see if the pattern repeats after following the guide.

If the idea of a clean install is not idea, you could try booting into the terminal only, connect to an Ethernet card if you have one and begin trying to “fix” whatever is happening with the display manager. Reinstalling various items and re-configuring others. I hesitate to give step by steps details as it could just make things worse if there are other issues involved.

If it happens again, on a brand new install, setup using the guide with the recommended OEM C kernel, then please open a ticket.

Fresh reinstall worked! Wish I knew what caused the issue, but hey, I have my laptop back now at least. Thanks everyone!

(During boot I see the same red herring message, but then it boots normally anyway).


Awesome to hear. One thing that makes this stuff so much easier is TimeShift.

It’s fantastic when something stops working one day, you’re not sure what - think restore and move on. Also nice as you can revisit the problem restore point later to dig in should you want to or even just compare changed files.

Now, if you’re still seeing GNOME Display Manager appearing (even though this is resolved in terms of it working), that is not something I have ever seen on a clean install and gives me pause.

If it happens again and no longer works right again, do open a support ticket and link to this.