[RESPONDED] OS doesn't load (Unexpected number of charge port count)

Laptop worked OK for couple months and then suddenly OS (Ubuntu 23.04) stopped loading with such message:

cros-usbpd-charger cros-usbpd-charger.2.auto: Unexpected number of charge port count

Related to this code

  • Noticed problems with usb ports: i could boot from usb drive from the third attempt (it sometimes just doesn’t see usb boot there)
  • It does load ubuntu in recovery mode
  • I’ve tried reinstalling Ubuntu (both 22.10 and 23.04) from scratch
  • All 4 ports can charge the laptop
  • I’ve tried to load with all 4 adapters being de-attached
  • I’ve tried to load with 1 USB-C adapter and three others non-usb (hdmi, ethernet, etc)

Does the led on the side of the laptop blink with a pattern of colors during the boot?
If yes, what is the exact pattern?

Also, what is your machine?

Machine is 12Th Gen. Bios version is “3.05”

Right, when it first happened, the blinking happened as well:
It was all green, orange and then “BBGGGBBG”.

With blinking it even couldn’t reach the GRUB loader. After opening the laptop, deattaching cables, and attaching again - blinking went away - and then it stopped loading properly after the “ports count” message.
(And as I remember, the message about ports was there before, it just could pass through before)

This message is harmless, and just indicates that the cros-usbpd-charger driver is not loading. This is a good thing, as it is not compatible with the Framework Laptop.

If you have quiet in your kernel commandline, it is probably suppressing all of the actual interesting messages that will tell you what is failing. You should remove it for one or two boots, which you can do by pressing e in your GRUB menu to change the parameters for a single boot.

Since it boots in recovery mode, it is not likely to be a kernel problem. Recovery mode still loads up the operating system before dropping you into a recovery shell; you should be able to observe the same message about cros-usbpd-charger there if you run dmesg.

1 Like

@DHowett you’re right. This message is still showing in dmesg.

If loading without quiet splash params, it stucks with such a screen (nothing suspicious for me):
huge apologizes for sending such a photo-screenshot

Does it boot properly if you add nomodeset in the kernel command line in the GRUB menu?
(tell me if you need more guidance to try that out)

It’s a bit weird that the blinking does not occur anymore…
It does come back even when you boot with the USB-C power cable plugged in? (in this case the blinking, if it comes back, would occur on the side where the cable is plugged)

Yes, now, it can’t load OS no matter how: with USB-C power cable pluggined in (directly, or via framework adapter), or without.

But, first day when issue appeared - i could load OS via disconnecting power from USB-C when loading (connecting back, when already in Ubuntu). This trick helped me out to load 2-3 times, and then it stopped loading OS no matter if power cable is connected or not.

I’ve tried nomodeset (and removing quiet), and it did load.
Last messages before it started Gnome were:

cros-uspbd-charger.2.auto: Unexpected number of charge port count
Bluetooth: hci0: Malformed MSFT vendor event: 0x02

Also, it started OS with limited graphics support (like when in recovery mode)

Ok, it looks like you have a problem with your mainboard, as the symptoms are similar to mine in this thread, except for the blink codes, which is why I asked again about them.

You’d better contact Support. Diagnostic steps will take a while (and yes it can feel redundant and slow), but I encourage you to patiently follow their instructions. Then, if the mainboard is still under warranty, and they determine the damage is not customer-inflicted, they will likely propose you a free replacement.

1 Like

Please open a support ticket.