[RESOLVED] Wayland mega thread and Fractional scaling (Fedora 39 Beta)

Hi, thank you for sharing your experience. Do you mind sharing exactly what you did to fix Slack? I’m not sure what this permission is and I’ve tried several solutions I’ve found related to fractional scaling on Wayland for electron apps and nothing worked so for now I’m just running it in the browser.

Of course! If you installed slack from the app store (which means you installed the flatpak version), you can install flatseal from the app store (I used the flathub version, but all versions should work).

Open flatseal, select slack on the left panel, there should be a permission called “fallback to x11 windowing system” on the right, enable that and restart slack.

If you installed slack from the official site (this means you installed the RPM version), then you will probably need to edit the slack desktop file.

I am happy to share more details, just let me know what do you need.

1 Like

Thank you so much, that was it! I’m new to the flatpak world and whenever I heard of flatseal it was in the context of enabling access to the filesystem, so I had no Idea it can do so much more.

If you don’t mind, can you share the changes you made to the desktop file for Code?
For now i’ve resorted to add code --enable-features=UseOzonePlatform --enable-features=WaylandWindowDecorations --ozone-platform-hint=auto to a bash file and launch it like this, for some reason if I tried to add these to the .desktop file it was not working.

Flatseal is a GUI tool for flatpak permission management, it can manage most (if not all) the permissions of a flatpak app.

I use the RPM version of codium (a open-source fork of code), this means that the desktop can be found in /usr/share/applications/. I think you need to change both codium.desktop and codium-url-handler.desktop.

Here is my codium.desktop:

[Desktop Entry]
Comment=Code Editing. Redefined.
GenericName=Text Editor
Exec=/usr/share/codium/codium --enable-features=WaylandWindowDecorations --ozone-platform-hint=auto --unity-launch %F

[Desktop Action new-empty-window]
Name=New Empty Window
Exec=/usr/share/codium/codium --enable-features=WaylandWindowDecorations --ozone-platform-hint=auto  --new-window %F

and here is my codium-url-handler.desktop:

[Desktop Entry]
Name=VSCodium - URL Handler
Comment=Code Editing. Redefined.
GenericName=Text Editor
Exec=/usr/share/codium/codium --enable-features=UseOzonePlatform --ozone-platform=wayland --open-url %U
1 Like

Thank you I think this section did the trick, last time I edited I only added the options to the [Desktop Entry] section. And I hadn’t modified the url-handler file either the first time.

@ClaudiuIO, I think I mistyped he url-handler desktop file, “useOzonePlatform” should not be necessary, nor do I think “WaylandWindowDecorations” is necessary if you are using custom window title bar provided by vscode.

Merging this to an existing thread and into the correct forum section (Linux) as I would not have seen in General.

1 Like

With Fedora 39 fully updated, in a terminal,

gsettings set org.gnome.mutter experimental-features "['scale-monitor-framebuffer']"

This assumes you’re on Fedora Workstation 39 (GNOME) and you have not changed your defaults away from Wayland.

Now, Electron applications are their own thing. You will likely have to make individual changes to their launchers as some were built with X in mind. Using --force-device-scale-factor flag to the .desktop file and so on. I personally avoid electron applications if I can.

1 Like

Thanks @Matt_Hartley I did end up trying that command a bunch but it doesn’t work when the system boots to X11 by default.

I know above you said you don’t experience it on a fresh install. Mine is only a couple days older and I just ran dnf upgrade this morning, so I’m not sure why it’s still happening.

Edit: a-ha, mutter 45.0-9.fc39 is available, let’s see…

Edit 2: No dice, sorry. I want to help you here, so I can try to provide logs, I am just not too familiar with which logs to provide.

I think the reason why you still see the issue in your environment is because Matt tested the issue on another BIOS unit while the AMD Batch 1 user’s BIOS version is still 3.02. You can check the following thread. This issue is already filed on the Fedora Bugzilla with the log file. So, maybe you don’t have to provide logs.

1 Like

Thanks @junaruga! Will give a BIOS upgrade a go.

1 Like

I was wondering why my F39 haven’t received any update for several days, which is not the typical fedora software update frequency.

Turns out, it seems like I need to enable “Fedora 39 - Test Update” repo in the software repository section in store.

I guess I will need to turn it off once fedora 39 is released.

It seems that now is in the frozen state. That is new updates of the RPM packages are limited except the blocker issues.

For example, this RPM package:

This update will not be pushed to stable until freeze is lifted from Fedora 39.

Don’t worry this is a typical Fedora’s release process.


One more thing.

The command option --enablerepo=updates-testing is to enable the testing repo for only this command. It doesn’t enable the testing repository as a default.

$ sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-192e09f394

You can check your enabled repository by the command below.

$ dnf repolist enabled
1 Like

Yep, this is what was happening.

I have a machine setup with 3.02 BIOS now. Doing some Ubuntu testing today, then will bounce this over later this afternoon to see what is up on this front.

1 Like

Confirmed, 3.02 issue, works fine in my testing release of 3.03.


1 Like

Has anyone been able to get the VLC flatpak working under Wayland? VLC launches and can play media–I can hear audio–but it is invisible. I’ve tried enabling x11-fallback via Flatseal to no avail. It works fine in an X11 Gnome session for some reason. I’m on BIOS 3.03.

@mphi I have vlc flatpak on fedora 39 beta running fine. It does not support wayland window (Can't get wayland mode anymore with flatpak VLC · Issue #149 · flathub/org.videolan.VLC · GitHub), so the text is blurry, but the video plays fine.

Is there a particular video you are testing? I have tested with https://youtu.be/4yUMOK9dOQc 720P downloaded via Freetube.

@Matt_Hartley Sorry for the late reply, but confirming now that 3.03 BIOS resolves this issue for me.

1 Like

Delighted to hear it! I’ll mark this as resolved.