[RESPONDED] Fedora 39 XFCE on AMD?

Just curious if anyone has tried the XFCE spin on the new AMD models, or plans to?

If not, I guess I’ll report back if I find any problems, lol. I suppose I might just go with GNOME, but I kinda dig the “old school” feel of XFCE.

Bear in mind, I’m a Linux noob, so if I do run into issues with XFCE, my report probably won’t include how to fix it, unless it’s something pretty simple, :wink:

1 Like

Haven’t seen anyone, but my typical spin is XFCE + i3, so I guess if you run into trouble, you’ll have someone else in your batch that’s doing something similar! :stuck_out_tongue:

I feel like most issues I’ve seen have involved Wayland, so I’m hopeful that X11 will be smoother.

1 Like

Probably not, but we’ll see, lol. I might just run “vanilla” Fedora 39, GNOME, but plan to at least give XFCE a go.

For those exploring the same path, always check if you’re on updated BIOS :slight_smile:

So, I haven’t installed anything yet, but I got my laptop yesterday and spent a little time playing around with Xfce, KDE and GNOME on live USBs (all Fedora 39). I really like Xfce, but I’m leaning towards just using GNOME. There are a few small details that GNOME has “out of the box” that I like. KDE was nice, but felt a bit “bloated.” It was full of apps I wouldn’t use (I’m sure I could remove them) and as soon as I connected to the internet, it gave a popup asking me to set up a KDE Wallet account. It seems like a nice DE, but it seemed to fall into a sort of awkward place for me. It sat right between the others. Not quite the “old-school simplicity” of Xfce and yet missing some of the stock features I found and liked in GNOME.

I didn’t get into anything advanced. I didn’t even try to use the fingerprint reader. But with each one I made sure Wi-Fi and bluetooth worked, connected to the internet, messed with the package manager and file system manager. Watched a 4K video, browsed the internet a bit, etc. KDE and GNOME both worked flawlessly. At least as far as I went with them. Wi-Fi, bluetooth, video playback, doing some basic display and input configuration, etc. It all just worked.

Xfce was mostly the same, but I did run into a couple small glitches. First, when hovering the cursor over a menu with cascading options that auto-expand when you mouse over, this would sometimes stop working. I’d have to move the cursor away and come back in order for the cascading options to start opening again. Not a big deal, but strange, since it almost felt like lag at times. Also, when browsing the Framework site certain imbedded videos/animations would fail and top playing. The biggest issue was MAJOR screen tearing when scrolling vertically. It was especially bad when scrolling fast/moderate, but slowly scrolling caused jittering that was also jarring to the eyes. I searched for a feature I saw mentioned online in the Window Manager Tweaks, but it wasn’t there. I accidentally unchecked “compositing” and then re-checked. For some reason, after this the screen tearing completely went away. Scrolling was smooth after that. No idea if this issue would exist on a proper install or if it would come and go the same way. One way or another, I imagine there is a fix. But with how smooth GNOME worked “out of the box” for me, and considering the fact that it’s officially supported by Framework, I’ll probably go that route for now. I do like Xfce, but maybe I’ll switch it up later.

The biggest issue was MAJOR screen tearing when scrolling vertically. It was especially bad when scrolling fast/moderate

Yep, this is a common thing on many XFCE installations. You can fix it with a compositor, or some GPU drivers will let you vsync in your xorg settings.

1 Like

Otherwise, it seemed to work fine. I didn’t get super deep into things, but I played around a bit and didn’t have any real problems. Even the screen tearing, while annoying, wouldn’t prevent me from getting things done. It was just ugly when scrolling.

Ultimately, the little things that made me lean GNOME probably have options and workarounds in Xfce. I’m sure I could have gone Xfce and been happy. But I decided to give stock Fedora a shot first. I’ve still got my Xfce live USB sitting here, so I may play around with it some more.

Now that I have a machine in hand, I just wanted to say that I didn’t have to do anything to get XFCE to work OOTB :slight_smile:

The only two changes I made were

  • DPI for fonts (the default was too small for me)
  • I added TearFree to my Xorg config to prevent tearing, and it works great


Section "OutputClass"
     Identifier "AMD"
     MatchDriver "amdgpu"
     Driver "amdgpu"
     Option "TearFree" "true"
1 Like

While untested by me personally at this time, this looks right to me. This would be your best bet as you’re in X11 land.