[RESONDED] Not powering down anymore (kernel 6.4 Arch Linux)

Today I noticed that the laptop does not power off anymore.
The shutdown sequence completes normally, but then the screen becomes black but stays on, the keyboard stays lit, the power button too, and it keeps being this way indefinitely, without ever completely shutting down.
I forced power off it by holding the power button.
I tried three times again to boot then to tell it to shut down, but each time the same problem happened.

12th gen 1280p, Artix Linux, Kernel 6.4.1-artix1-1, packages up-to-date.

Anybody got the same problem?
I am going to try a motherboard reset.


Good day, Mapleleaf!

My Framework runs Arch Linux and had the same issue after updating to kernel 6.4.
I have resolved this issue by downgrading to 6.3.9.

If the issue with kernel 6.4+ isn’t resolved after my exams, I will see if I can either a better solution or actually patch the kernel myself.

Stefhen Beorn Heck

1 Like

@StefhenBH Wow, thanks a lot!!
I didn’t expect to see somebody even propose to patch the kernel!!
I will take your advice and downgrade.
Thanks again!!

PS: I’ll also update to title to reflect the real root cause that you pinpointed.

PPS: It works with your workaround!

I haven’t experienced this on my 11th Gen running Arch Linux, that’s an interesting bug

There is another thread about this issue:

1 Like

Hello, I have had the same issue on my Intel NUC11PAHi5 mini PC. I’m using Arch linux, Xanmod kernel compiled by myself. This issue arrives straight from kernel 6.4.0+.

The issue is what you described, PC shuts down, but the power button is lit up and USB devices are on. It stays on indefinitely. Pressing the power button doesn’t turn it back on again.

Downgrading to 6.3+ is okay, but 6.3.13 is EOL.

Any solution is greatly appreciated.

I found this issue on Archlinux forum as well:


The suggested solution to disable TPM from kernel command line didn’t work for me (I made sure to rebuild grub configuration with grub-mkconfig). Disabling it from BIOS might work but I haven’t tried it.

1 Like

Just taking notes guys, 6.4.x is arch’s latest stable?

6.4.6 at the moment

Edit: And now it’s 6.4.7.

On my system, I still have the issue with Linux 6.4.7.

Note that the issue isn’t intermittent, but it happens 100% of the time, so installed 6.4.7, rebooted, turned off PC, and it won’t shut down completely.

Kust being curious, if they aren’t powering down completely, is the device still available on the network?

I want to update on my side: all is fine for me with the kernel 6.4.7-artix1-1.
As far as I am concerned, the problem is solved.

@Sourav_Goswami Is there any chance that you could try a clean install including the latest kernel? And also: could you try the official kernel instead of your custom-compiled one? (Easy to miss some option during kernel config… especially e.g. the very option designed to fix the issue…)