[RESPONDED] AMD Batch 1 Guild

I am curious about 4800, cause I’ve got that right now, so we’ll see when mine arrives I suppose. I’ve got the Crucial CT16G48C40S5.

1 Like

I do notice that this is a dual rank kit, and most of the validated list are single rank with the exception of one of the ECC ones, so I wonder if that might be causing issues

Although, assuming the Amazon listing for the Crucial 5600 mhz kit is correct, it is a dual rank kit that others have confirmed is working. I can’t seem to find the product sheet for it so if someone could link it here, that would be great.

1 Like

Oops, I thought you asked me to copy it! It was no trouble anyway; good luck with your delivery!

1 Like

Not so easy to find in the thread’s history but updated : delivery complete !! :grin:


I had the same issue with 23.10, 22.04 seems to be working just fine though for me at least (most notably after installing the oem kernel and what not).

1 Like

For us stuck-in-Anchorage, AK sub-guild: looks like its just been released from customs!

Oct 17 2023 06:41 am


International shipment release - Import


Sadly no, still not here… at least tomorrow is wednesday :slight_smile: So two whole days just waiting in the depot roundabout 35km from me. Could have got it faster by walking there and getting it myself :grin:


I need Fedex to hurry up, I’ve been sitting here anxious on if my RAM is gonna be compatible or not for so long LOL it’s just been sitting in a facility an hour away for 8 hours

And here we go ! :blush:


Launched! Windows 11 in this case but my SSD was already pre installed with a Windows 11/Linux Mint combo. Will have to check how Mint holds up.

Mainly because I took my sweet time unboxing and reading the manual, it took me 20 minutes to DIY it and boot it up.

I’m curious to how it holds up in general. I’ll be running several benchmarks

Hardware list:

  • Ryzen 5 7640u
  • SK Hynix P31 Gold 2 TB
  • Crucial 2x 32 GB 5600 MHz (CT2K32G56C46S5)

FedEx once again visited the wrong house so right before they left I noticed and intercepted them before they were gone.


Happy to announce that mine is FINALLY here!!!

And even happier to announce that my 4800mhz cl40 RAM is working!!! Once again, my kit is Crucial CT16G48C40S5.


Out of curiosity, why Debian? I love Debian but it moves a bit to slow for my liking :slight_smile:

I work on KDE packaging for Debian. Also yes Debian stable moves slowly but if you’re ready to cope with rare breakages, testing is close to being a rolling distro.


My FW is now operational with the kit from Kingston (KF556S40IBK2-64)! Thanks again to @0xFF and others for reporting working modules early on!

There are apparently some instances where the 5200s are working (not sure which, yet), but I would avoid 5200s if you are still shopping around (or can still return yours). Not worth the hassle. Besides, who doesn’t like more speed?!

Best of luck to all that are still waiting!


LOL no problem, I’m just glad it’s there now. Thank you!

Oml I’m just imagining you performing a steak out of your own neighborhood just laying in wait for your moment…


You don’t want to know how accurate you are…:stuck_out_tongue_winking_eye:


For everyone who wanted to know some benchmarks I made a post on reddit.


Seconded. I had been using Debian from about Woody (3.0) to Squeeze (6), when I moved my daily drivers to Gentoo, which I’ve been using since. For much of my Debian time I used “testing” and never had any major issues, sans the odd dependency problem which would resolve no more than a day or two later. Even today for non-daily driver uses (e.g. Raspberry Pi, live USB drive) I use Debian and this thing continues to meet its main selling point as “rock solid”. Even with the “testing” branch which, as @coucouf points out, is pretty similar to a “rolling” distro. And compatibility is high as many third-party packages come in .deb (or .rpm).

I would certainly recommend people to try Debian stable, or testing if stable moves too slow for their liking.

In contrast, Ubuntu gives me pains and aches every… single… time… I’ve tried to use it (incl 22.10) until I ultimately lost all confidence. I’m obviously very biased on the matter, but in my view Ubuntu, as it is today, is an absolute disaster and train wreck. For regular 6mo release distros Fedora is, in my view, far superior.

1 Like