[RESPONDED] Linux Kernel Panic [AMD Framework 13, Ubuntu]

Hi all,

I installed Ubuntu 22.04 (I believe) on my Framework 13 AMD laptop (latest gen), and have been encountering kernel panics on every other startup. I’ll post my setup and a picture of what happened below.

I’m a newcomer to Linux (and using the Terminal), so please bear with me–if I have left something out or don’t know how to do something, please let me know.

Thank you all, I appreciate the help!

Framework 13 Laptop

AMD Ryzen 5 7640U

RAM: Crucial CT2K16G56C46S5 (32GB, 5600-SODIMM), taken from the supported RAM list.

Memory: WD Black SN850X 2TB

Linux version: Ubuntu 22.04

OEM: 6.5.0-1015 (I ran the uname -r command as instructed by the Ubuntu guide).

If it helps, here is the picture of the error message. It only shows up every other reboot.

Welcome to the community!

1 Like

Welcome to the community! Sounds like you have done everything right. Can you walk me through any changes or updates that brought you to this state?

  • At what stage did this take place? Was this immediately after you setup the OEM kernel and ran updates? Did this happen later on merely after running updates? Did anything with hardware change anywhere along the line?

  • Do you have access to another NVMe drive to test against? I have a sneaking suspicion the drive is related here, but it would be interesting to see if there is different behavior here. If not, I can look and see find one in my office and see if I can replicate. I don’t think I have one readily available to test against myself.

Hey Matt, thanks so much for getting back to me so promptly.

IIRC, I think this happened some time after I finished the the completion guide and then installed updates. The first few boots were fine.

I think this started happening probably on my fourth or fifth time rebooting, and since then, it’s been happening every other time. Also, I haven’t done anything to the hardware after the initial setup.

I don’t have another NVMe drive, but I can order another one to test it against, if you think it makes sense. Or do you think I should go through the drive installation process again? Maybe take out the drive and slot it back in and see if that changes anything?

Thanks again for the help! Very cool to get an answer directly from Matt himself :smile:


Don’t know if it helps but I think that maybe I have the same issue. I have been using this laptop for a while now (part of the 1st batch) so I don’t think it’s an hardware issue. I mindlessly update everything and I often reboot when I see a kernel updates so maybe it’s not related but that’s when I saw this kernel panic for the first time. Seems to be very consistent i.e. reset, warm boot, panic, hard reset, cold boot, OK, restart, warm boot, panic, hard reset, cold boot, OK…

It only happens when I select “ubuntu” after a reset but I never saw a panic when I select a specific kernel. I do not always get the exact same error (see both pictures) but because one seems to be related to the efi_store, I checked the content here but I am unsure of what I see or if it could be related:

$ sudo find efi

Hi, did you solve your problem? I have the same issue here…