[RESPONDED] AMD RZ616 wifi card doesn't work with 6GHz on kernel 6.7

At least it doesn’t for me. After some digging into the kernel code, it looks like a new mechanism (CLC, country location control) was implemented in the kernel driver for 6.7 (driver’s name is mt7921e), but it didn’t work at all for me.

Anyway, the solution on my system was to disable CLC like this:

echo "options mt7921_common disable_clc=1" | sudo tee /etc/modprobe.d/mt7921-kernel67-fix.conf

There are a ton of patches on the linux-wireless mailing list regarding the mt7921 and this mechanism, so maybe this will be fixed in later releases.


Appreciate you sharing your workaround @Kelvie , Thank you. :slight_smile:

Thank you! 6GHz hasn’t worked for weeks now on my laptop and I couldn’t find anything about what changed. That solution worked.