[RESPONDED] WiFi 6e working in Ubuntu for anyone?

Does anyone have WiFi 6e working in Ubuntu? I have tried Ubuntu 23.10, then reinstalled with 22.04 LTS (following the guide, including linux-docs/ubuntu-22.04-fw-16.md at main · FrameworkComputer/linux-docs · GitHub). I can connect to 5Ghz without any problems. I can see the 6e network in Linux, but when I try to connect it just times out with error:

Activation: (wifi) association took too long, failing activation

I also booted into Windows 11 (from USB with the updated AMD drivers) and connected to my 6e network right away, so I know the card works.

Works fine here with Kde Neon (Ubuntu 22.04 + all KDE plasma).
Make sure you enable the hwe kernels.
Framework tells you to use this guide:

But I would rather just enable the HWE kernel with kernel - How to enable HWE on Ubuntu 22.04 - Ask Ubuntu as that integrates these with grub etc. and you don’t have to do manual manipulations

I would agree with this. Back when I tested 22.04 w/ hwe on my original 11th gen Framework, that kernel worked best for enabling Wifi 6.

Ideally OEM D kernel for LTS Ubuntu, then this section of the guide.

I as long as you have the correct firmware, you should not have any issues.

sudo dmesg | grep mt7921e