[RESPONDED] CPU gets stuck at 0.2 GHz

Did you reach out to Framework Support? I mean, it was under warranty…so…there’s that.

This is the part were we do our own QC (unfortunately)…and inform them on poorly behaving units…some of which should have not left the factories.

No I did not reach out to support, I followed this thread and there was no resolution to the issue from framework so I figured it was a design defect, this is the first I am reaching out to anyone about the issue - it takes a lot for me to reach out to support.

I’ve been having this issue running PopOS 22.04. I did a clean install of Ubuntu 20.04, and the problem persisted. After playing around a bit more, I’m beginning to see the pattern:

  • Whenever my laptop is running on battery, there is no issue
  • Whenever it’s plugged in through a USB-C expansion slot (I have two), it takes anywhere between 1-10 minutes for the laptop to throttle down to 200MHz and it remains “locked” there, and at the same time, the laptop appears to no longer be charging.
  • Whenever I plug the charger directly into the laptop (so instead of an expansion card), I have no issues either.

Since I have two USB-C expansion cards, I think it’s unlikely that it’s a hardware issue. Both expansion cards actually work fine when I hook my monitor up to them. I’m still guessing it’s somehow a driver issue, but I’m not sure.

Need details: CPU / mainboard generation / variant, and BIOS version.

Batch: #6 DIY
OS: Ubuntu 20.04.05 LTS
CPU: 11th Gen i5
BIOS: 3.10

Since I have a workaround for my particular issue, I’ve been lazy about systematically diagnosing the issue. I’ll make a bit more of an effort tomorrow to see if any particular port or expansion card seems to be the issue and report back here.

1 Like

I’ve just about had it with this laptop. It’s impossible to get any work done with these constant issues. I lost several hundreds of dollars just from the missed work this laptop caused me. And also the 1TB expansion card disconnects randomly - #104 by lbkNhubert . Oddly enough these started happening more frequently after the warranty expired. Framework doesn’t care about their users , they knew issues like these have been happening for over a while and still no permanent solution from them. This will be my only and last laptop I purchase from them.

I had the same issue on my 12th gen laptop, CPU clock on windows was stuck at 0.4 GHz, making the laptop borderline unusable. The fan was clear. Removing and reinserting the CMOS battery fixed the issue.

I hope Framework addresses this with the upcoming BIOS update.

Hi there, don’t know if anybody else tried this, but I may have found a workaround to keep this problem from happening:
The only caveats are that it keeps the CPU from using the full speed available, but it keeps the laptop stable, and if you update the BIOS it resets the settings, so make sure to keep an eye on that.
If you go into BIOS and set CPU to Max-Non Turbo Performance and Disable Intel SpeedStep, SpeedShift and Turbo Boost Max, then it should keep the problem from happening.
This is with a Intel 11 i5, 16gb RAM and Windows 11, but it also fixed the problem on a Intel 12 i5 as well.
Hope this helps somebody!

I’m having the same problem, stuck at .2 randomly, but it has become full-time now. Running 11 Gen with Win 11. Rebooting from cold overnight no longer fixes it. It even boots at this speed! I tried disabling SpeedStep, and that worked for a day. I thought it was fixed, but now it’s stuck for several days at .2. Computer becomes useless.

I would like to point out that this same issue is happening with other brands like Dell, HP, etc, that use this same i7 processor, so its not just Framework! No one seems to have a fix, so I can only conclude the problem is a bad Intel chip design or batch. Unfortunately, someone on here has indicated it is happening with the 12 gen as well. The other thing I notice is that the fan never comes on and when it is working normally the laptop becomes very hot. I replugged the fan but it made no diff. I will try replacing the paste and will try a new fan.

Framework really needs to make fixing this issue their number one priority, or I fear for their future (and ours, as customers).

@Dennis_Miller Now I’m afraid I didn’t test turning them off individually to see which one might be the offending one, but did you turn them all off/down like in my post? Just curious because I want to help, and turning them all off may be the factor in keeping this problem from restarting.

I stumbled across this thread from AskUbtuntu - 22.04 runs too slow and it looks like I’m suffering from the same issue. I originally thought that it was just 22.04 being terrible, but several different tools report the same issues others are reporting.

I have a Batch #3 | 12th gen - i7 1280p machine with 64 GB of RAM running Ubuntu 22.04.

The issues are painfully noticeable on any Electron Apps, and reporting tools won’t show my Frequencies at above 400 MHz. I didn’t catch it sooner because System Monitor shows everything as a percentage, and I guess everything was just as a percentage of 400 MHz instead of 4.8 GHz.

That’s quite harsh of you to say so! What arguments do you have to support this?
If it were really so many people having this issue, don’t you think that they would make it their number #1 priority?

There are a lot of issues currently on the framework laptop. Battery draining (both normal and CMOS) and CPUs overheating/underperforming are just some of them.

I just bought my framework even though I know these issues can and probably will arise because I support the statement framework has, not because I want the latest tech that is 100% reliable.

It sucks to not be able to use a product 100%, but if you really have such big issues and your support ticket is going nowhere I suggest to ask for a refund and try a framework at a later time in your life.

Did you check out the latest bios update to see if it has any changes?

1 Like

Update–I seem to have fixed the problem by replacing the paste on the CPU. It has been running perfectly for two days now, and I’m starting to think it will be ok. When I removed the heat pipe, it looked like an excessive amount of paste on the CPU–very thick. The paste instructions usually specify a minimum amount of paste. I spread it very thinly and reassembled, and it has been perfect since. I may have reset the CMOS batt also by accident. I didn’t see a good way to remove it but moved it around–may have momentarily disconnected. Later realized most MBs have a switch to reset CMOS but have not bothered to research that for this MB. I also reset the BIOS to Optimal, removing all changes. The computer still gets very hot, and the fan still does not come on. Have ordered a new fan, should be here tomorrow. Temps show very high, near max, but still working fine, but I just do internet and email–no gaming, etc. I don’t think BIOS mods will help this issue long-term.

@Dennis_Miller Fair enough, glad to hear that you found an option that works for you! Hope it continues to work well and that the new fan helps!

I ended up opening a support ticket and followed all of the steps to no avail. It was the final, last-ditch, recommendation that’s seemingly fixed everything.

A hard CMOS reset by taking the battery out for 15 mins (read, like 2 hours) then putting it back in. The subsequent boot was near instantaneous.

Upon starting back up, Discord (kill me) started up almost instantly and my Chrome (still kill me) tabs are actually responsive. I can hear my fans on, and my cope command: sudo watch cpupower monitor is reporting numbers far above 400 all across the board.

System Monitor is also reporting far lower percentages all across the board, which I find incredibly interesting. I guess something must have been screwed up from the get-go and everything was just as a fraction of either 400 MHz or some equally terrible number.

I just pray that the issue doesn’t decide to rear its ugly head again the moment I close my ticket.

I notice that @Dennis_Miller mentioned that they may have also reset the CMOS battery so I wonder if that’s some sort of commonality.

After seeing Yoshiko’s post, I think that the issue may be somehow resolved with a CMOS reset only. For those still struggling with this issue, give it a try. It is not necessary to wait 15 minutes. This is a myth widely believed on the internet. I won’t go into the tech reasons, but a momentary disconnect is all that is necessary to reset the CMOS circuit. All I did was push the CMOS batt down for a second, breaking the connection with the top contacts. I wasn’t sure that would work, but apparently, it did. Removing the batt for a sec would be better, more certain. I’m still wondering if there is a CMOS reset button or switch on the mobo.

Since the repair, the computer works WAY better than it ever had. My boots are also very fast now. I had upgraded to bios 3.10 and installed win 11 22H2 update. Still, the paste seemed excessive and there was a big crack in the paste down the middle of the processor, which may have caused problems. Thinner is better.

Removing the CMOS Battery fixing it makes sense, because it resets the BIOS to Factory settings and somehow resets the issue, It’s interesting that there’s more paste than needed though…

A week later, still working fine. Resetting BIOS seemed to do the trick. Very fast now.

1 Like

I guess I am not affected :slight_smile:

You can run this with watch to see how CPUs behave.

grep 'MHz' /proc/cpuinfo
cpu MHz         : 533.456
cpu MHz         : 2100.000
cpu MHz         : 485.018
cpu MHz         : 684.178
cpu MHz         : 859.227
cpu MHz         : 1400.000
cpu MHz         : 2100.000
cpu MHz         : 2100.000
cpu MHz         : 465.049
cpu MHz         : 2100.000
cpu MHz         : 2100.000
cpu MHz         : 2100.000
cpu MHz         : 2100.000
cpu MHz         : 2100.000
cpu MHz         : 2100.000
cpu MHz         : 2100.000

I’ve been battling this for a while now… For some reason it seems to happen more with 3rd party power bricks than with the OEM one…

On Ubuntu 20.04 it was happening pretty constantly for me, after doing a clean install to 22.04 it seemed to not be happening as much, but lately it’s been so bad. I wish there was a solution to this…