[RESPONDED] Did my GPU just glitch in the last hour?

  • I’m running Linux Mint 21.1 Cinnamon Edition
  • This is an 11th gen Intel Framework laptop.

All of a sudden, I was having issues with Edge Beta for Linux and Chrome not rendering some web pages properly (such as YouTube & Facebook). Basically, it’s glitchy to the point of being unusable (mainly, web page elements are failing to render and things look “intermittent”). I was able to turn hardware acceleration off on Chrome and it corrected the issue (obviously not without impact on performance). Edge is so bad that the settings page is not usable so I can’t turn off acceleration to test this there (I assume it should be the same result since they use the same engine). Firefox works.

So I was wondering if something in my integrated GPU just broke.

I’ve rebooted a couple of times. I’ve even switched kernels. No difference.

I tried running a simple benchmark, glmark2 and, without knowing for sure what it’s supposed to look like, it looks like it may be rendering fine.

Finally I went and booted with an Ubuntu Live USB & tried Chrome & tried Edge & they both worked. I thought that this ruled out a hardware issue. Then I rebooted to my normal install.

Issues are gone. Now I am changing my mind & thinking that this seems inconsistent with a software issue since there should have been no updates happening between boots so if things were broken before due to a software issue they should have remained broken after this last reboot.

Did I just have some sort of intermittent hardware failure?

Yup, I’ve seen it again and yup, it’s working fine again.

How would I validate my GPU Intel graphics if I see this issue happening again?

Everything described feels like hardware acceleration is not playing nicely (which is why I do not document how to enable it because of stuff like this).

With default browser settings, no hardware acceleration, see if this takes place again.

Yes, I think hardware acceleration was not playing nicely with the Chromium engine; but the question is why. I’m not sure if this setting has been there in Chrome from the very beginning of the browser, but, in my experience, it being enabled has been the default for years (I don’t know if the install process does some kind of a hardware check?) so enabling it is not a thing that anyone generally needs to do to take advantage of this capability. Of course, that means it’s been enabled all along and I did not see this issue until the very day I wrote the OP (after using the laptop for well over a year).

At some point it went away but I checked yesterday and noticed that I had mistakenly left it disabled on Chrome (so it’s possible that I might have missed the issue happening). It is now enabled after I changed this setting yesterday & I am not seeing the issue. On Edge I had meant to leave it disabled all along since the graphic issues are so severe that there is no way to disable it from the GUI.

I guess I’ll see what happens.

1 Like