[RESPONDED] Dual Displays Not Working with Framework Laptop 12th Gen on Linux Mint Cinnamon 21.2

Hello Framework Linux Forum.

I am a new user trying to daily-drive Linux Mint on my new Framework Laptop 13 and this is my first forum post. However, I am running into an issue when connecting to an external monitor to dual display alongside the laptop display. Specifically, when I connect the HDMI (laptop) to DVI (monitor) cable the laptop display shuts off and I can only use the external monitor. While I have had experiences with other machines in which my cursor can “travel” to the seemingly nonfunctioning display, in this case my cursor cannot leave this single external monitor. In exploring the Display settings, Linux Mint states there are, in fact, two displays as shown by clicking the drop down menu option to select a different display, but only shows one display in the layout screen and provides no options for either mirroring, displaying, or even rearranging them. I have attached some screenshots below.

Prior to purchasing my Framework Laptop, I installed Linux Mint Cinnamon 21.1 earlier this year (later upgrading to 21.2) on an HP Stream I bought for $200 in 2018 to get familiar with Linux Mint over the course of several months. All the same peripherals (i.e., cables, dock, monitor, mouse, and keyboard) worked immediately without issues, allowing me to successfully run dual displays (the Stream’s display + my external monitor; This same set up is also successful my Windows 10 HP 2-in-1 from work). I have spent much of this weekend searching both this forum, Linux Mint forums, and the general internet for information on what is causing this and how to remedy it; no luck. I hope someone here might be able to help me out.

Here is what I have tried so far:

Rebooting with all configurations of cables plugged in before/after boot.
Checking for updated BIOS (I am fully updated).
Booting a Linux Mint 21.1 live session from a USB (got the same problem).
All combinations of powering the external monitor on/off before/after boot.

Here are my system and hardware details:

Framework Laptop 13
CPU: 12th Gen Intel Core i5-1240P
BIOS: 3.05
Distro: Linux Mint 21.2 Cinnamon (Cinnamon 5.8.4)
Kernel: 5.15.0-87-generic
Memory: 32GB
Storage: 2TB

Monitor: Dell E228WFP, 1680 x 1050, 60Hz
Connection: HDMI to DVI

Dock: Kensington SD470P USB-C & USB 3.0 Dual 4K Docking Station (Model: M01486)
Connection: USB-C

Here are the details for that HP machine I mentioned that worked without issue on the same equipment and same distro:

Product number: X7S52UA
Product name: HP Stream - 14-ax040wm
CPU: Intel® Celeron® N3060 (1.6 GHz base frequency, up to 2.48 GHz burst frequency, 2 MB cache, 2 cores)
Memory: 8GB
Storage: 32GB + 126GB SD Card

I am at a loss for what to try next and could use some help.

Thank you.

Screen Label

Hi @William_Bryant ,

Welcome to the forums, maybe do first try ubuntu live 22.04 and Fedora 38 live,
and lets check if those two supported distribution has the same issue with your dual monitor setup, see if it works there. If it does, them maybe we can replicate configs to make it work with linux mint.

cheers! :slight_smile:

Hi Loell,

Thank you for getting back to my initial inquiry. I am writing to confirm receipt of your message. However, I have been extraordinarily busy and not yet had the opportunity to try your recommendation. Additionally, I have been working with someone on the Linux Mint forum (you can follow our correspondence here). I hope to have some time to get back to this issue soon.

Thank you.

Hi everyone,

I am writing to follow up this post as my issue has been appropriately resolved (you can review the journey through the associated Linux Mint forum thread here).

The main interventions that resolved my issue were:

  1. Update and run a more modern kernel (at the time of this writing, I am using a 6.5.0 kernel).
  2. Download drivers for any peripherals (e.g., docks).

Additionally, always make sure your cables are functioning appropriately! After doing steps 1 and 2, I was still running into issues and it turns out that was due to a faulty USB-C cable running from my Framework Laptop to the dock!

I hope this information is helpful!