[RESPONDED] Can't use external monitor

Hey there,

I can’t use any external monitors with my framework. I have 11th gen framework and using Fedora 38 at the moment. Last year I was using Fedora 37 and I remembered that I could use an external monitor. Then I didn’t used one for a longer time and updated Fedora to 38. I can’t remember if the issue started before or after that.

I’ve already searched the forums but couldn’t find a solution. Then today I did a fresh install of Fedora 38 because I’ve read that there can be problems without a clean new install. After is installed Fedora 38 to my harddrive my monitor was working. I wasn’t able to change the solution, but it worked. So my monitor, the cable and my displayportcard worked.
Then I did all the upgrades after a fresh install (sudo dnf upgrade) and all of the sudden the monitor isn’t working again. I tried to reboot but in the setting I don’t see the external monitor listed.

I’ve read some things that maybe it’s a problem with the window manager I’m using? But my linux-knowledge isn’t going that far. I can’t think I’m the only one using Fedora 38 with an external monitor and having that problem? Is there some setting I need to change? I would really appreachiate any help.

The monitor is connected via displayport.

Thanks so much and it’s my first post, so I hopefully didn’t to anything wrong here.

There are several potential issues. 1) What monitor model are you using? 2) If you go into Settingg and choose Displays does the external monitor show up in the list? 3) Are you using Wayland (default) or did you change it to Xorg?

1 Like

Everything nadb asked and also, is this via a dock or using a supported DisplayPort expansion card?

My monitor is a gamingmonitor “Acer Predator”. I can look for a modelname if that is important. Before I did the fresh install I tried to connect my framework to another monitor as well, also with HDMI. It all didn’t worked.

Now, if my monitor is plugged in it isn’t listed in the display settings. Before I run the dnf update for the first time it was listed. I use Wayland and didn’t change anything. I really don’t know anything about window manangers or how they work. But I switched through all that were available (via the little icon on the botton right, just before I log into my user-account.)

The monitor is connected via an displayport expansion card. The cable is a normal displayport to displayport cable.

Thanks for the details, this helps.

  • Not entirely sure which exact model this is (helps when researching this further), but I will assume it’s something like the Acer Predator X34. If this is like this model, is there anything attached to the USB ports on the display?

  • This is Fedora 38 Workstation (GNOME), not one of the spins using another desktop environment)?

  • With the display attached, what is the output of xrandr --query (Even though this is a Wayland display server, it will show output for XWAYLAND)

That’s the output:

Screen 0: minimum 16 x 16, current 2256 x 1504, maximum 32767 x 32767
XWAYLAND0 connected primary 2256x1504+0+0 (normal left inverted right x axis y axis) 280mm x 190mm
2256x1504 59.93*+
1920x1440 59.90
1600x1200 59.87
1440x1080 59.99
1400x1050 59.98
1280x1024 59.89
1280x960 59.94
1152x864 59.96
1024x768 59.92
800x600 59.86
640x480 59.38
320x240 59.52
1920x1200 59.88
1680x1050 59.95
1440x900 59.89
1280x800 59.81
720x480 59.71
640x400 59.95
320x200 58.96
2048x1152 59.90
1920x1080 59.96
1600x900 59.95
1368x768 59.88
1280x720 59.86
1024x576 59.90
864x486 59.92
720x400 59.55
640x350 59.77

My monitor is a: 27’’ Acer Predator XB271HU. There is just the power- and displayportable attached, nothing else.

I use the regular Fedora 38 Workstation, not a spin.

Can it be that I need some kind of driver or something? It’s so weird. Again, the monitor was working right after the install. I really don’t get it. Being not able to use a monitor is a dealbreaker but I really really like Fedora as my main operating system. Hope I can find some kind of solution.

Thanks for the help so far!

Interesting, I suppose on live fedora 38, external monitor is working?
can we get output on same command?

I’ve tried the live version. Monitor isn’t working and isn’t detected by the system.
“xandr --query” isn’t working. Command not found.

Sorry you were saying that Fedora 37 got your external display working? can we try the 37 live? see if it’s still the case today?

So let’s give you an update.
With my hdmi-extensioncard, I tried a different monitor (with simply a hdmi slot), and it now functions. I am unable to determine if the problem is with my monitor alone or the displayport expansion card. My main monitor, however, won’t connect via HDMI. Although the monitor is listed, “no signal” remains.

The problem is still not resolved, but I have discovered a workaround that seems to work somewhat. I’m not happy that I can’t utilize my nice monitor and displayport, but I don’t want to put any more effort into this. So this thread may be closed from my perspective.

Thanks for all your help!

1 Like

Thanks for the update @Knueppelmann ,

will leave this open for now, you’ll never know if you or someone with similar issue will bump into a solution. :slight_smile:


1 Like