[RESPONDED] Fedora 39 AMD My Running Commentary on Kernel Updates

This is a running commentary about my system before/after performing a system update via Gnome’s Software app. If there’s another thread I should use, let me know. It may be useful for others that are interested in kernel updates on their Framework.

Starting Software Information:

Firmware Version: 03.03
OS Name: Fedora Linux 39 (Workstation Edition)
GNOME Version: 45.1
Windowing System: Wayland
Kernel Version: Linux 6.6.2-201.fc39.x86_64

Notes: sometimes when I open the laptop I get a full white screen with the ability to move the mouse cursor around. I have to do a hard reset to get back working. Other than that, system is great.

Update 2023.12.4

Kernel Version: Linux 6.6.3-200fc39

Update was successful. I’ve been using the laptop as normal; i.e., browsing web, doing Shopify work, chat apps, Windows VM, etc. My Dell 4k TB dock continues to perform well via USB-C in left rear module port (HDMI, mouse, keyboard).


Welcome to the community!

Appreciate you sharing your experiences with us. :slight_smile:

add kernel param amdgpu.graphics.sg=0 should fix this
also switch uma=auto to uma=game optimized in bios helps some

Update 2023.12.7
Kernel Version: Linux 6.6.4-200fc39

Update was successful. I’ve been using laptop as normal. I will take some performance measurements between now and the next kernel update.

1 Like

Just did an update. Still running really well. I performed the kernel param and bios config edits mentioned above regarding graphics corruption. However, unrelated, I’ve noticed that I prefer to have the system “lock” when the lid is closed. I’m going to look into how to make that happen in Fedora 39.

Update the typical screen lock settings were not working via the Gnome Settings app. I discovered this by reading the system logs and noticing an entry for “screen lock is locked down, not locking.” To get what I wanted, I had to use an app called “dconf-editor” to change a setting from “on” to “off” within: org.gnome.desktop.lockdown disable-lock-screen.

Gnome: 45.2
Kernel: 6.6.8-200.fc39.x86_64