[RESPONDED] Framework and PopOS

Hey folks - I’m a total newbie so I’m unsure if this is the most elegant way of doing it, but given that Pop uses kernelstub I figured I’d try adding the "quiet splash module_blacklist=hid_sensor_hub" to it. It works!

So, my kernelstub is:

sudo kernelstub -o "quiet splash module_blacklist=hid_sensor_hub mem_sleep_default=deep"

I’m happy to hear how this is bad & wrong, but man, keys work now.

1 Like

Hi @Neal_Knight , welcome :slight_smile:
What is this kernelstub command about? Is it to safe battery? Or has it something to do with some keys? Sorry for not fully understanding your comment.

I think he is referring to blacklisting the hid_sensor_hub module to workaround the 12th Gen motherboard bug as documented here. That way, you sacrifice ambient light sensor to make the Brightness keys work (F7 & F8). Does that help?

PopOS bundles kernelstub to help you easily manage kernel options without having to do so manually in the bootloader you use.

Yep, Esscan has it. One could also go spelunking in the boot files as well but kernelstub has worked pretty well thus far.

The ambient light sensor freaked out in Fedora (as documented), too - so I’m not super sad to see it gone.

Don’t worry. I’m using the same solution and it works perfectly. It even survives kernel upgrades. So that’s another bonus.

Hey all, cross posting this here as I’m getting the notifications to update my DBX firmware on Pop Os but also a warning that I can’t use USBc power to do it? Did anyone try this, and was it fine to just proceed?

@Neal_Knight are you using a bluetooth mice/keyboard by any chance? I’ve enabled this but then realised my bluetooth mouse doesn’t work anymore (it connects but doesn’t do anything).

I’ve already tried removing and re-adding the mice, but since it doesn’t work, I’m guessing its down to blocking all external hid devices

Does anyone have the problem that with an external curved monitor connected by USB-C that the display from the framework laptop is lagging?
I use the following screen settings:

Furthermore, is there a solution that the fans are not so loud?
I am using Pop!_OS 22.04 LTS and the intel Core i7-1185G7 11th Gen

How specifically is this connected via USB C? Dock, adapter, is there DP or HDMI connecting somewhere along the line?

Since this is Pop OS, that means Xorg as the default. Let’s take a look at xrandr. From a terminal, please run xrandr and then copy/paste the results here please.

If you want to try Wayland on Pop.
Another consideration is to use Wayland (which will need to be enabled).

  • Enabled Wayland in sudo gedit /etc/gdm3/custom.conf by setting WaylandEnable=true
  • Save, reboot, choose your user by clicking on it like normal. Now look to the bottom right (after clicking onto your username see image).

Thanks, Wayland is working very well. Is Wayland at a point to replace XORG and is there a way to boot automaticaly in to Wayland?

So out of curiosity, I set my Wayland option as shown above. Logged in once. Then powered off. Power on, logged in. I was logged in using Wayland.

Once I set it once as above, it stuck as the default for me. Single boot, 12th gen, fully up to date Pop OS 22.04. So yes, it will default for you. :slight_smile:

1 Like

I used Wayland for awhile with Pop and really enjoyed it. But there are a few apps that haven’t caught up. Zoom in particular would not allow screen sharing while running Wayland. So I had to switch back. Looking forward to trying it again in a few months when perhaps things have caught up to it more.

Pop!_OS guide has been updated for 22.04.

New items added, including fingerprint reader login usage.


Thanks for the comprehensive guide!

It all worked, but there is one discrepancy I found with some of the keys - brightness and airplane mode keys are only registered as F keys in PopOS.

The rest are recognized, for example “Audio next” and F6 are registered separately.

What this results in is - I can’t select the brightness down key, but I can select F7. So I can only use the brightness feature while holding the fn key to hit F7.
To compare with Audio next, you can use the actual key and not fn+key to trigger F6.

I’m curious if anyone found a way to register the remaining keys?

Hi @Matt_Hartley, will Pop!_OS guide be available again?

Due to time, staffing, etc, we’re laser focused on Ubuntu 22.04.3 and Fedora right now. That said, I will DM you the old guide - it is dated, meaning, it may absolutely be obsolete by now.

1 Like

Hey Matt

Can you share it with me as well? I can give it a run through on a FW13 AMD when I receive it (batch 2)

Sending, again, I don’t post this live as it is absolutely dated and untested at this point.

A reminder:

systemd-boot not grub, use System76 docs for using kernelstub usage (as you will not have grub parameters).


@Matt_Hartley also interested in the outdated guide! I might update it and publish an unofficial one on my blog - running PopOS on a FW13 11th Gen Intel so far without any issues.
Sleep works, function keys work, fingerprint auth works.


Hi @pmn It’s sent.

To anyone else reading this, I cannot stress this enough, this guide is super dated and has zero support. You will be better off on Ubuntu 22.04.3 with the recommended kernel or Fedora which have solid support.

1 Like