[RESPONDED] FW 16 - Wireless connectivity does not go above 30 Mbps in either Ubuntu or Windows

My partner and I just got FW 16’s and are having very limited network speeds on our wireless connections. I’m running Ubuntu 22.04.4 LTS and they are running Windows 11. We both verified on Speedtest.net and I have tried doing local steam transfers and nothing is downloading at more than 30 Mbps.

When I run iw dev wlp4s0 link my output is

Connected to 24:94:cb:a4:d7:73 (on wlp4s0)
	SSID: <Redacted>
	freq: 2437
	RX: 90239444 bytes (97315 packets)
	TX: 85535398 bytes (94064 packets)
	signal: -45 dBm
	rx bitrate: 173.3 MBit/s VHT-MCS 8 short GI VHT-NSS 2
	tx bitrate: 130.0 MBit/s MCS 15

	bss flags:	short-preamble
	dtim period:	1
	beacon int:	100

I have tried iw wlp4s0 set power_save off and iw reg set US. I also tried modifying /etc/NetworkManager/conf.d and set wifi.powersave = 2. I even found some posts saying that secure boot can interfere with the network drivers and turned it off. None of these fixes produced any changes.

I disassembled my computer and reseated the network card and verified it is the RZ616 chip which should be WiFi 6 rated, which my router is as well.

I have not gone as in depth into my partner’s computer but we updated their AMD drivers and their download speeds actually went down to about 10 Mbps.

I am at my wit’s end, is there any advice anyone can give? Thank you!

FYI - WiFi is mostly like using a HUB. The slowest active “talking” device will determine the link speed. So if one of your kids is watching a youtube video, and has bad connectivity while connected to the same antenna you would connect, you won’t get a faster speed. Period.
Of course, your AP has to be able to handle the speed.
My FW16, connected to my own equipment (Mikrotik Access points - Wifi 5 only), provides 220Mbps… over Wifi:

Also, you sure your AP can handle the speed? Thick Walls?
Put your FW16 next to your AP (1 meter), and to the test. Disable Bluetooth while you do the test also.

Yes, I have already verified all the other normal wifi items. No other people on the network, no active traffic at the time of testing. I have a small house and distance to router does not change any of the results. My network does not have this speed issue with other devices. I have not tested without bluetooth specifically and will do so next time I am home.

I am glad that your wireless works well and knew that mine should have better performance, that is why I am asking for help. I personally suspect a driver or configuration issue of some kind. Thank you.

What also often happens, is that the AP is not really compatible with the connected client. In your case, as this happens with 2 FW16, it seems to be the case.
Don’t know if new firmware would fix it. Don’t think it’s the drivers as you are using 2 different OS’s.

1 Like

If this is happening after both following the guides (this includes the recommended firmware mentioned in our Ubuntu guide and the drivers provided by Framework in the Windows guide), then this may be an incompatibility with the chipset and the AP.

1 Like

I’m having similar issues, but in 24.04, I don’t see any reference to an additional Mediatek driver in the completion guide for that version. Is it expected that the newer kernel in 24.04 has it resolved?

I did install the additonal driver in my other install (Zorin 17.1 built on ubuntu 22.04) and am seeing much better performance than native ubuntu 24.04

We are seeing a regression with AX210 where power save does best disabled. I am reproducing and tracking now for Fedora.

Testing against MediaTek now, I suspect power save is also causing a drop in speed here as well.

Something to try, on 24.04 - assuming nothing custom with drivers was done, of course.

To determine if power save is on (and it likely is):

iw dev | grep Interface | awk '{print $2}' | xargs -I {} iw dev {} get power_save

If this returns: Power save: on

Run this script:

echo -e "[connection]\nwifi.powersave = 2" | sudo tee /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf && sleep 1 && echo -e "\033[1;33mProcess is complete"

and then

sudo systemctl restart NetworkManager

Check again:

iw dev | grep Interface | awk '{print $2}' | xargs -I {} iw dev {} get power_save

Should output: Power save: off

Hate this and want it gone?

sudo rm /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

and then

sudo systemctl restart NetworkManager

My FW16 is on Win11. I had a similar issue before. What I did is to set the preferred 802.11 protocol to 802.11ac - basically ignores backward compatibility to really old access points.