[RESPONDED] Just got my laptop, have a strange keyboard issue under Linux


Just got my framework 13 with Ryzen processor and installed and I’m having a keyboard mapping issue I can’t resolve. My forward slash and question mark key are being mapped to the rt ctrl key. Makes it really challenging to type any path statement in terminal without a forward slash. I’ve verified the mapping by pulling up the Settings > Keyboard > View Keyboard Layout and I can see the Rt Ctrl key engaging when I try to hit forward slash.

I can’t find this issue documented and opened a service ticket with Framework and waiting for a response. Any help is appreciated:

  • Which OS (Operating System)? - Ubuntu 22.04.3
  • Which release of your OS (Operating System / Windows 10, 11, Distribution of Linux)? 22.04.3 LTS, Kernel: 6.1.0-1-24-oem, Gnome 42.9
  • Which Framework laptop (11th, 12th or 13th generation Framework laptop) are you asking for support with? 13 with Ryzen 7840u

There maybe more mapping issues as well, this is just the one that keeps popping up.

In a terminal, what does localectl give you?

System Locale: LANG=en_US.UTF-8
VC Keymap: n/a
X11 Layout: us
X11 Model: pc105

Hum…odd. And I assume the keyboard is physically a US keyboard?

Maybe a wire or two from the bottom row got crossed…

That’s what I assume. Hoping framework support will ship me a new one.

does it happen in bios/windows too? if so then hardware else really bizarre software issue

Hi @Michael_Wester , welcome to the forums.

Glad you’ve filed a ticket already, as it’s looking like a hardware issue.
hopefully you’ll get a resolutions soon. :slight_smile:

@Ian_Burgess I haven’t loaded windows on it yet, so not sure. I’m trying to make this my linux only machine :slight_smile: I’ve been in the BIOS, but haven’t tried the forward slash or question mark, but I do know that when connected to an external keyboard the keys work just fine. I’m beginnning to agree this is probably a hardware issue. Hoping Framework support responds pretty soon.

Please make sure to update your BIOS to the latest for AMD 7040 Series. AMD Ryzen 7040 Series BIOS 3.03 and Driver Bundle Beta

Yeah, mine came with that Bios version already installed.

Unless something has changed and I was misinformed, I believe the laptop would have come with 3.02 not the released as stable as of yesterday 3.03. Can you confirm your BIOS release?

sudo dmidecode -s bios-version

Yep, you’re correct it is 3.02, not 03. I clearly read it wrong.

Hi @Michael_Wester ,

Let us know when you’ve tried BIOS 3.03, see if issue still persist.



got my Framework 13 with Ryzen 7840u last Thursday with a similar Problem.

Batch2 with upgraded Bios 3.03.

Both Ctrl keys are dead. Tried with Linux, Windows and the Swap Ctrl-FN Bios option, no reaction whatsoever. External Keyboard works fine, everything else works.

I wonder if i could take apart the input cover myself and check the keyboard connectors/wiring, kinda following this guide:

ticket is still pending

Thank you letting us know. Ticket volume is through the roof due to order modifications for AMD. We appreciate your patience!