[RESPONDED] MT7922 poor performance, Fedora 6.7.7-200.fc39.x86_64

Access point is an Asus RT-AX88U, 802.11ax using 5Ghz.

rtt min/avg/max/mdev = 1.626/14.116/21.042/5.346 ms

Most pings to the AP appear to be in the 15ms range.

I would blame the AP except the Intel AX210-based system 50cm away from my Framework gets

Minimum = 1ms, Maximum = 9ms, Average = 1ms

Interestingly the AX210 system gets 4ms in Linux. I wonder whether it’s a measurement difference.

Could be a bug needing to be reported. You could compare it against the AX210 if you have one available to test against. I have not had any issues per se with the MT7922.

AMD with MT7922 here too.

mtr gives me more consistent results.

Also, I see ~ 15ms to the access point (with mtr), but www.google.com can be 1-2 ms less. Probably something about the stack/firewall on the access point/router.

Can you try disabling power saving in NetworkManager if you’re using it?

I’m running Fedora GNOME so using NM. By default:

$ nmcli c s '<SSID>' |grep power
802-11-wireless.powersave:              0 (default)

and based on wavemon output this defaults to power saving on.

In this state, mtr <access point> shows an average of 11-12 ms, but mtr www.google.com is almost the same, at 12-13 ms.

After disabling power save:

$ nmcli c mod '<SSID>' 802-11-wireless.powersave 2

and toggling WiFi from the GNOME quick settings to let the new setting take effect, wavemon shows power-save off.

With this setting, mtr <access point> is indeed lower now, 1-2 ms, but mtr www.google.com is still the same as before.

It looks like to me (and I remember seeing this in some other report about this apparent jitter/latency with MT adapters) that power saving doesn’t actually have as much real performance hit as a pure ICMP-based test like ping/mtr might suggest.

All my speed tests (I like https://speed.cloudflare.com/) show no issues with jitter or unexpectedly high latency. Upstream latency/bufferbloat improved as expected after I added QoS/queue management on the AP/router. Throughput saturates the ISP’s expected speeds (400Mbps down, 100Mbps up). The 5GHz channel I use has no other APs/signals as far as I can tell from scans.

2 Likes