[RESPONDED] Poor WiFi signal on AX210 WiFi and Manjaro

Following Power management - ArchWiki I setup a udev rule with power_save off.

I don’t see any improvement in the signal level from when power_save was on.

│wlp166s0 - wdev 1, phy 0, reg: n/a                                            │
│                                                                              │
│link quality: 90%  (63/70)                                                    │
│======================================================================        │
│                                                                              │
│                                                                              │
│signal level: -47 dBm (0.02 uW)                                               │
│=============================================                                 │
│                                                                              │
├─Packet Counts────────────────────────────────────────────────────────────────┤
│RX: 8k (10.36 MiB), drop: 98 (1.3%)                                           │
│TX: 3k (332.65 KiB), retries: 55 (2.1%)                                       │
│mode: Managed, connected to: ..., time: 3:45m, inactive: 1.6s   │
│freq: 5220 MHz, ctr1: 5230 MHz, channel: 44 (width: 40 MHz), bands: 2         │
│beacons: 2,185, avg sig: -43 dBm, interval: 0.1s, DTIM: 3                     │
│rx rate: 180.0 MBit/s VHT-MCS 9 40MHz VHT-NSS 1                               │
│tx rate: 400.0 MBit/s VHT-MCS 9 40MHz short GI VHT-NSS 2                      │
│tx power: 22 dBm (158.49 mW), power save: off                                 │
│retry short/long: 7/4, rts/cts: off, frag: off                                │
│wlp166s0 #2 (UP RUNNING BROADCAST MULTICAST)                                  │

@Hoshang Ok, maybe I sound silly but, have you checked the wifi card and the antenna? Like, the connection between the wifi card and the motherboard, then the connections between the antenna cables and the wifi card, and as a last resort, the connection to the antenna in the display assembly?

Also, do you really see that the power saving is disabled, using the same “iw dev” command as previously?

This is solid advice. I once mashed something (years ago), happens.

1 Like

Thanks @Mapleleaf I reseated the wifi card and wifi antenna cables. No improvement.

I also installed Ubuntu 22.04 and did not observe improvement in the wifi signal.

1 Like

Just tested wavemon on my Fedora 37 install.

It’s not unusual to see the applet dip down, yet when you run speed tests, etc, see no issues whatsoever.

My WAP is about 6 feet in front of me. My wifi stability and speed are great.

Both of the AP you indicated I believe are mesh products. I too, am on a mesh product. One of the things I see happen is that one node is handing access when it’s not the actual closest. Nearly impossible to replicate this, but I’ve seen it happen on other laptops and OS’ in the past.

The band, barriers and other factors can also affect signal strength. My Eero node is five feet away from me, and my signal shows at 65 out of 70. Yet my speeds and performance are flawless.

So when you’re indicating poor wifi performance, are you using the details of the signal strength as your metric or the actual performance? In my experience, 99.9% of the time issues around wifi are not the laptop - they are usually surrounding conditions (that can change all the time).

It’s also worth approaching your WAP to see if the signal jumps suddenly, walk around to different areas of the room, but use wavemon vs networkmanger for the best info.

I had the same problem and this solved it for me Internet speed is slow - #24 by Goldy1940 - Network - Manjaro Linux Forum.

Went from like 0.05mb/s to like 20mb/s.

1 Like

Thanks Kevin. This guide disables new wifi protocol and only allow legacy b and g protocol. This could cause issue with a lot of new wifi anthenas that no longer support legacy protocols. I will give a try to see if I can see improvement with my home wifi anthena.

I know this is an old topic, but I only just got my framework laptop and have noticed the Wi-Fi range is poor compared to any other wireless device that I have. I have found a lot of people who have a similar experience, but no one seems to have an explanation or a solution.
Do you have anymore information of this since last year?


No my issue has not been resolved and the Wifi quality has not been good. I can see my collegues laptop and macbook on the same location getting way better Wifi signal. I tried different kernels as recommended.

For what its worth, I have done some additional testing with another Linux laptop (Lenovo Thinkpad) I have and have uncovered something interesting.

The Framework and the Thinkpad were both the exact same distance from the AP. The Framework, as we know, has poor signal only showing one bar and reporting to be a low quality link. The Thinkpad shows nearly full bars and reports a good quality link.
However, when I run iwconfig on both devices, the dbm readings, link quality, and download speeds appear to be nearly identical, in fact, the Framework probably performs a little better.

I wonder if perhaps Arch might be reporting that the wireless link is worse than what it actually is?

What exactly is reporting that?

The network connection icon in the task manager (KDE) shows low bars and poor quality. Further investigation in system settings or clicking the icon and going to details also reports poor quality.

Running iwconfig or wavemon reports far better signal strength.

Assuming that there is no hardware issues or limitations with the antenna or networking card, It would be reasonable to assume that iwconfig and wavemon are reporting the correct and accurate information given that it is comparable to similar devices operating at the same distance from the AP.

So kde, are you also running kde on the thinkpad?

Is kde actually reporting signal strength or something more abstract like signal “quality” or link speed or something?

I would like to say that KDE was being used on the Thinkpad, but the laptop isn’t actually mine and I don’t have access to it right now to confirm 100%.

It would be something more abstract. I imagine a different DE would query the exact same information. I just mentioned KDE in case it helped since the information being queried was from the GUI.

Regardless, I have USB booted into an Ubuntu installation on the Framework to confirm that it does consistently show poor Wi-Fi performance through the GUI. So probably not an Arch exclusive issue?

Different tools interpret the same data differently, it isn’t exactly defined how signal strength or whatever translates into bars. I do remember a “scandal” where a phone manufacturer inflated the bars they were showing to make it look like they had better radios but no idea who that was.

If iwconfig gives you the same dbm the antennas are very likely fine (though keep in mind db is logarithmic so small difference in number makes a big difference in value).

Even different tools on the same de may interpret it differently.

The only difference between different linux flavours here is how new the wifi firmware and driver is and the ax210 has been pretty stable for ages so you should not see much difference even with the relatively old ubuntu stuff.

Yeah, I figured that relying on the icon and system reported information wouldn’t exactly be 100% accurate and comparable across different devices. However, since there was a difference, and this difference can also be observed in other devices, like my mobile and desktop, I figured that additional testing with CLI tools like iwconfig was warranted.

I didn’t just run iwconfig once at a single distance. I had both devices side by side on a piano chair and moved them around at difference distances from the AP as well as tested both Wi-Fi channels. The results were very consistent. Both devices reported almost equal dbm across all test with the Framework averaging perhaps a little better in overall signal strength.

At least for me, this was enough the alleviate my concerns that I had originally shared with OP regarding a problem with the Frameworks signal strength.

1 Like