[RESPONDED] Section of right-side of the keyboard no longer works

I have a Framework 13 laptop ordered last year and arrived in Sept 2022. A few days ago I’ve started having issues with the ‘Enter’ and ‘Backspace’ keys suddenly stop working, but appears to work intermittently.

Today, I discovered more keys are not responding and the complete list includes:

  • ‘+/=’ “plus/equal” key
  • backspace
  • ‘} ]’ “right bracket” key
  • “quote” key
  • enter

I’m currently running Kubuntu 23.04 with X11. I’ve tried rebooting, and reseating the keyboard connector with no success. Using an external keyboard also does not cause the keyboard to work again (per this suggestion here.

Is this a case where the keyboard has failed and I should open a support ticket?

Thanks in advance!

Yes it sure does sound like you should open a support ticket.

Do these keys work in the BIOS?

Have you checked the connector cable and its socket?

1 Like

Yes, however the first thing we will ask is for you to try this on a Live USB of Ubuntu (although live Kubuntu is fine for this type of error) to see if the issue is present there in a live environment as well.

I’ve got a 1st generation Framework running Windows and have just started having the same thing. Started a couple of days with the backspace and enter buttons intermittently not working, and has now expanded to the same keys mentioned in the OP. Still intermittent, and when the keys work they work totally normally, but then they all stop at the same time as well. I plan on investigating more tomorrow, but since I found this thread with such a similar issue I thought I’d see if you figured out your issue?

Also, mine seems to happen more when I’m lying back and have the laptop propped at an angle with the keyboard more vertically oriented. Will check connectors tomorrow.

May indeed be hardware, however, we would want to test this in a clean OS environment to validate OS/software vs hardware. For Linux users, this would be Fedora or Ubuntu 22.04 live usb.

Since this is a Linux thread, I’ll assume you were referring to Linux. If not, I can move it onto its own thread.

No, running Windows 10. I just thought that the issue with it being the exact same keys and the intermittent nature as in the OP, made it worth posting in this thread even with a different OS, in case a solution to that one had been found that gave me a place to start checking.

I’m leaning to a hardware connection since it really only seems to happen from bed when propped up against my legs (I’m recovering from an accident and am kind of stuck in bed for a bit)

For what it’s worth, I have tested in Windows prior to creating this thread and it was exhibiting the same problems. This feels more like a hardware issue and might be tagged incorrectly. Your best path forward is to open an RMA case if you’re still within the warranty period as it’ll eventually stop working. I used on-screen keyboard for the missing keys while that was processing.

My thought was it failed due to heat. There’s no fan in that region, and I would frequently use it on top of soft surfaces which would cover some of the air vents on the bottom. The top of the computer would often get warm to the touch. Was curious if you had a similar experience.

1 Like

Thanks. No longer in warranty, had the laptop for a bit over 2 years now. Was the replacement for you just a new keyboard? And that has solved your problem?

As for heat, could be. I do have it on soft surfaces fairly regularly, I’m definitely one that uses a laptop on the lap. The bottom can get pretty warm sometimes, but never noticed the top getting too warm. And I have a utility that monitors core temp and that has stayed well below the limits.

Ah, gotcha. Thanks for the clarification. For Windows, you will want to open a ticket for sure.

1 Like

Well, just thought I’d chime in that I’m having a bit of a similar problem, except pressing down on the ride side of the keyboard with some force fixes it for roughly 24 hours (First gen 13" running windows and all). I’ll open a ticket if it gets unfix-able or more annoying but so far doing alright with my little fix