[RESPONDED] Signal quality problems? Can't get 4K displays to work

I received my DIY AMD 7840U Framework notebook last Monday. I installed a Crucial P3 4TB 2280 NVMe SSD and a Kingston Fury DDR5-5600 2x32GB RAM kit. On the SSD i installed Arch Linux. Setup went smooth and easy and everything is working quite well and very stable.
Except for one thing: I can’t really make external displays work properly.
I have configured both right ports and the back left with USB-C expansion cards and the front left with USB-A.
To connect my two iiyama PL2893UH displays, i tried these adapters and docking stations:

  1. HP Thunderbolt 3 G2 dock
  2. HP Thunderbolt 3 Elite Dock (HSTNN-CX01)
  3. i-tec C31DUALDPDOCKPD (USB-C DP alt mode)
  4. i-tec C31NANODOCKLANPD (USB-C DP alt mode)
  5. The original Framework HDMI adapter, that i ordered together with the notebook itself

To rule out wiring issues and other hardware problems, i did test all of the mentioned adapters with the following PCs:

  1. Valve Steam Deck(no Thunderbolt support, only USB docks and adapters tested)
  2. HP EliteBook 840 G6
  3. HP EliteBook 840 G8
  4. HP ZBook 17 G4

All of them could drive at least one display in 4K(3840x2160) 60Hz. The Steam Deck and the ZBook had no problem with both displays running at 4K 60Hz. The results were pretty much independent of the dock or adapter used. For the heck of it, i also tried the Framework adapter on these devices. Rest assured, 4K 60Hz was not a problem at all. So at this point i’m sure, my display hardware is not the problem here.

With the Framework notebook results were completely different. Whenever i tried setting a display to a resolution higher than 2560x1440 i ran into trouble. It would either flicker or not display anything at all(no signal). Two displays could only operate at 1920x1080 max. each. Results were the same across the board, no matter which adapter i used, or which port on the notebook i used. Not even omitting the expansion card and plugging directly into the board would change the results. The notebook came with the latest firmware installed. Despite that, i tried flashing it again. No change.
Out of frustration i replaced Arch Linux with Windows 10 first, then Windows 11. Installing all Windows updates and the official Framework driver package. Again without any change in results.

At this point i’m out of ideas.
Is there anything else i could try? Am i missing something?

Welcome to the community!

We don’t test against any specific docks, but we do officially suggest and test against HDMI and DP expansion cards as that is hardware we control.

Did anything happen to appear in the logs that shed some light on things?

After doing some research, it seems like i wasted a lot of time doing these tests.
Windows 10 is not officially supported on this APU, so that might be the problem here. On Windows 11 i got it to work after updating the AMD platform driver. So i think it’s not a hardware problem after all.
On Linux that’s a different story. I read that there’s a problem with the scatter gather support on this APU with RAM at 64GB or more. Like here: What DRAM/memory is supported by Framework Laptop 13 (AMD Ryzen™ 7040 Series)? Unfortunately, i can’t run the notebook with only one of the DIMMs to get below the problematic 64GB. When i tried, the screen would stay blank and fans spinning slowly, not ramping up even after 15 minutes of wait. It does not matter which of the two DIMMs i try and it also makes no difference if the single module is in Slot 0 or Slot 1.
Supposedly the 64GB+ problem fixed with Kernel 6.5. Even though i am running 6.6 on Arch, the problem is actually not solved at all. The logs show a lot of amdgpu related memory problems. The best i can do is 1920x1080 on one screen and only when running the LTS kernel.
Following a suggestion in another post in this forum, i tried Kubuntu 23.10. and it works there. But only with X11. It falls flat with Wayland just like Arch does. Mind you the Steam Deck desktop also uses Wayland and it works there. So it seems like the issue really is a weird compatibility problem with this combination of kernel, APU and Wayland. Probably also Thunderbolt, as the situation is even less stable with docks using that.
I will see if i can gather some more info on this problem and file bugreports to the appropriate channels.
As for this post, I consider it solved. It’s not a Framework problem after all.

Well for one you can disable scatter gather using a kernel param and for the other only using one 32gb dimm should work (and has at least in my teasting) so that is a different issue.

I meant to reply sooner, but was caught up by this pesky Error 304 bug that seems to haunt quite a few people here.
I agree the single module problem is a different issue and non-related.
Also the amdgpu.sg_display=0 parameter unfortunately had no effect. I checked it to be active and it is, but changes nothing. In the meantime i tried Kubuntu with almost the same result. It works on X11, but not on Wayland. In addition to that, the Wayland session randomly freezes with the applications running but you can’t interact with the system anymore.

Sorry, i can’t figure out how to mark this as solved. As a workaround i will be using X11 until the problems with Wayland are fixed. It’s in the works, but not a Framework issue.