USB4 external display support

  • 13" Ryzen 7840U (64G/1T)
  • Win11 Pro
  • USB-C in left-rear and right-front slots (you’ll see why shortly), USB-A in front-left, HDMI in rear-right
  • 3.03 BIOS
  • Anker 568 USB-4 dock

Laptop is a flawless performer with one exception: when the dock plugged into one of the USB4 ports, after a few minutes the two external displays start flickering and then will go completely black. I have plugged in another USB4 laptop (a Dell Latitude 7420) into the same dock, and it works flawlessly. When I plug the dock into (the only display capable) USB3.2 port on the framework, it works fine (just no 40Gb/s performance). So as of now I’m stuck with simply leaving a USB-C module in slot 4 (right-front) and USB3.2.

As far as I can tell the other components in the dock are working fine (USB & NIC). Only displays seem to have issues.

Has anyone else seen USB4 display issues in their Ryzen framework?

I’ve got the Anker 778, and haven’t seen issues like that on my AMD board. I did have a monitor occasionally go out for a little bit on the 11th-gen Intel board before this, but I did update the dock firmware in-between, so that might have fixed it.
It looks like Anker’s firmware update tool does support the 568, so it’s probably worth trying that:

I am on Linux, so it’s possible there’s a Windows-specific issue, but I expect it’s most likely the dock firmware having some minor bugs.

I tried a firmware update using their tool (there was an update available), but no change in behavior sadly.

1 Like

Welp, my dock did the weird screens blanking out thing again several times last night, despite having never done that when connected to the AMD board before.

So it looks like my issue is probably unrelated. Though since my AMD board does seem to sometimes not recognize the dock until a few restarts (the Intel one always recognized it fine, other than the occasional screen blanking), it’s possible that the AMD board does have some flakiness in regards to docks. Though given the intermittent nature of my issue, determining where the actual problem is would be tricky.

Interesting note on the Anker web page for the 778: “Not compatible with M1/M2 MacBooks, or Asus laptops with an AMD CPU.”. That’s very specific to Asus, but it wouldn’t be surprising if the same issues applied to Framework laptops.

@Kevin_Fleming, thanks for that. I would swear to you that that note wasn’t on there when I bought the dock, but I’m willing to bet that you are correct, given that it works flawlessly with Intel machines.

1 Like