[RESPONDED] Slackware Install - change startup resolution

So I’m working on installing Slackware 15 but the resolution is to small for me.
(I’m using the aGPU currently, but the eGPU was doing the same on my 7840HS.)

I’ve tried adding these to the commandline on grub:

  • video=1280x800
  • video=vesafb:1280x800
  • video=efifb:1280x800
    I’ve also used: vesafb:off and efifb:off, but that causes the screen to stay blank or locks it up.

The screen is readable until the udev rules take hold, then it’s super tiny.

lsmod only shows ‘video’ - no amd or radeon with it so I suspect I don’t have the driver yet and that would be fixed after the install.
(This is to get to the installer and before installing.)

Are there any tricks?

UPDATE: Thanks to a user at Linux Questions, they pointed out just setting the font.

To do this:
setfont /usr/share/kbd/consolefonts/ter-732b.psf.gz

This makes it usable so I can continue. =)

Hi @Adam_Southerland ,

Interesting choice of distro to run on the FW 16, do keep us posted on how go with slackware, instead of the supported ones like current versions of Ubuntu and Fedora. :slight_smile:

cheers!

  • I did install Ubuntu first and then remembered why I don’t use it. It worked, or at least the pieces I needed worked like it should. (I don’t like snapd and it normally breaks without me breaking it, but it may take time.)
  • I also tried Fedora and didn’t like the desktop.
  • I have OpenSUSE installed which is nice so far and it looks like everything works.

Slackware will take me some time. It is installed, but I don’t think it’s detecting the keyboard. The default kernel maybe to old.

I’ll continue posting my updates as they occur.

Here is a log of what I am doing or done already… This will be repeated in the near future so might as well log it here for now. :smile:
(Just bought a 2TB M.2 2230 SSD and awaiting it’s arrival.)

  1. Booted the Slackware 15 (Stable) Installer from a USB
  2. After the boot, I ran this command so I could read the screen:
    setfont /usr/share/kbd/consolefonts/ter-732b.psf.gz
    
  3. Partitioned my disk from cfdisk --zero /dev/nvme0n1 # (This will clear any previous partitions)
    • 100MB vfat for EFI
    • 32GB Linux swap
    • 64GB Linux filesystem for Slackware
    • 64GB Linux filesystem for openSuse/Ubuntu/Fedora/~your distro here~
      • I use this second system to troubleshoot and finish setting up Slackware until I figure out what I need to do.
  4. Run setup and install all of Slackware.
    • I did run the elilo installer at the end and told it to create an entry. This did not boot for me and I don’t know why yet. So, it’s broke at this point.
  5. Installed another distro beside it (I used OpenSUSE, but any should be fine and I’ll call this my Recovery OS)
  6. From within my Recovery OS
    1. Open a terminal and run sudo su # so I stay as root while I work
    2. Mount Slackware and required filesystems & chroot into it
      mkdir /mnt/slackware
      mount /dev/nvme0n1p3 /mnt/slackware
      mount /dev/nvme0n1p1 /mnt/slackware/boot/efi
      mount -t proc proc /mnt/slackware/proc
      mount -t sysfs sys /mnt/slackware/sys
      mount -o bind /dev /mnt/slackware/dev
      mount -t devpts pts /mnt/slackware/dev/pts
      cp /etc/resolv.conf /mnt/slackware/etc/resolve.conf
      chroot /mnt/slackware /bin/bash
      source /etc/profile
      
    3. Here, I setup my Slackware mirror and performed a slackpkg update, install-new , upgrade-all and clean-system (each command independently)
    4. Update my initrd.gz (latest kernel at this time is 5.15.145)
      /usr/share/mkinitrd/mkintrd_command_generator.sh -k 5.15.145 | bash
      
    5. At this point, I rebooted into Slackware and it booted successfully with a functional keyboard and it detected USB!!!
    6. The font is HUGE right now, so I ran setconsolefont and set it to a normal size font.
    7. Install fbdev so I can start X slackpkg install xf86-video-fbdev
    8. Here I will be checking to see if everything is working.
      1. Missing proper video driver; fbdev does work
      2. Missing network driver (it trys to use asus_wmi)
      3. Mouse and Keyboard appear to work well
      4. The RJ45 adapter does work, so that makes the next part simpler

Next, I’m upgrading to Slackware Current - I did find an ISO and a Mini-ISO installer for this. I upgraded Slackware 15 to Current though and that took some time.

There you have it! With Slackware Current, it’s working nicely! All the major parts anyhow: Wifi, USB, Keyboard, Trackpad, iGPU; I still have things untested… Like Audio, the dedicated GPU, finger print sensor, etc… I’ll try and test these tomorrow.

When I get my new SSD, I’ll test it all over again… Using the Slackware Current Mini ISO directly =)

1 Like

UPDATE: I got my new SSD this morning and installed Slackware Current from a USB and it worked first try.

The resolution used to install was normal, after install was normal too. KDE defaulted to native resolution, but that was a quick update.

It looks like Slackware Current is working. I haven’t tested the fingerprint scanner, web cam, mic or dedicated GPU. Speakers, trackpad, keyboard all work.

I didnt like Ubuntu that much too, but now I am using Tuxedo OS 3, they basically cut out all the things I didnt like (mostly snapd) :slight_smile: