[RESPONDED] Black screen on start up

I’m having an issue where whenever I start up my laptop, it’s just a black screen, unless I press f4, and fix broken packages in the safety mode. But I have to do that every time I start the machine. I’ve tried Ubuntu 24.4, Kubuntu 24.4, and Ubuntu Budgie 24.4. I’ll give the 22.04 versions a try.

All the parts for the laptop were bought from framework.

16 × AMD Ryzen 7 7840HS w/ Radeon 780M Graphics
60.6 GiB of RAM

1 Like

I installed 22.04 Mint, and it works fine now.

I’m have a similar issue. Haven’t tried 22 yet, perhaps worth a shot. Do you have the 7700s GPU or just the iGPU?

I have the 7700, but it’s not getting recognized right now, which is irritating. I installed the 20.04 drivers from the radeon driver page. But nothings has changed. I was mistaken, the mint version i’m running is 21.3

Yeah I was getting some error messages about gpu firmware missing so I think it maybe that. I did get the other just fans expansion bay so I might try swapping to that later

Just a PSA:

Kevin, I realize that this is a solved problem for you.

I’d like to know if it was the same set of packages that broke each time, or different sets of packages? Use dpkg -l >LIST_OF_PACKAGES.txt or apt list --installed >LIST_OF_PACKAGES.txt commands to make the list of packages, and then run to see what changed. Then publish the results here, please.

Hey Jeff, I’m not sure if it was the same packages, but I’ve just settled into Kubuntu 22.04 for now. I’ll try creating a backup of this version, and trying the 24.04 version later, but I have some deadlines I need to try getting done, so I’ll try getting back to this after hopefully.