[RESPONDED] Ubuntu 22.04 trackpad scroll speed

I’ve had my AMD FW13 for a few days now and love everything about it so far. I’m currently dual-booting Windows 11 and Ubuntu 22.04 LTS, both encrypted with BitLocker and LUKS, respectively.
All running smooth as butter.

The official guides have been a great help, especially the Ubuntu one to ensure I have everything working as expected - fingerprint reader, ambient light sensor, the works.

However, there is a small annoyance I’m hoping someone here can answer once and for all…

How do I reduce the trackpad two-finger scroll speed in Ubuntu 22.04?!

I’ve been all over the internet trying different things and nothing is working so far (outside of a Firefox tweak only). Even one suggestion here ([RESPONDED] A Few Irritating bugs on Ubuntu 22.04 - #10 by Owen) which doesn’t work for me as xinput doesn’t list anything with any Scrolling Pixel Distance value.

Everything else I find/try is either outdated, referencing slightly different tools, or flat out does nothing.
It’s not unusable, just very, very sensitive, so scrolling is way too fast. When using Windows the scroll speed is absolutely fine - scrolling across the trackpad relative to screen space. But in Ubuntu I can scroll a whole screen’s worth of page (be it in a browser or system app) with just 2cm of finger movement. This makes pinch-to-zoom in browser windows and maps insane too.

So, is there anyone out there, on the CURRENT version of Ubuntu 22.04 LTS, with a FW13 laptop that has had this problem and resolved it at system level - not just for Firefox?

I really hope so. Cheers.

1 Like

Hi @moody_influence,

There is not anything that allows you to easily change the speed of two finger scrolling. Especially on Wayland, although I suspect it will make its way to Ubuntu and other distros in the future.

That said, it is “possible” to do this on X11, but it is not userfriendly and I would not be able to support it if it went sideways.

Best bet at this point in time.

  • File a bug with Ubuntu, let them know this is something that matters to you.

  • Disable two finger scrolling altogether. I agree, it is sensitive and I generally have it turned off. Activities, search Touchpad.

  • If scrolling matters and I know it does for some of our customers, a mouse with a wheel may be the best stop-gap at this point. Wish I had better suggestions.


If you’re feeling adventurous, you can boot into X instead of Wayland and try some stuff. But remember, this is not recommended or supported officially. So if it goes sideways, I can’t help.

  • Log out of Ubuntu, still powered on.
  • Look to the bottom right, choose the gear, click it, select Xorg. Login.

This not great advice is asking users to install synaptics
( xserver-xorg-input-synaptics) vs libinput, which is old and super dated. May not even work - not recommended on a laptop you are not ready to do a fresh install with if it goes sideways. :slight_smile:

Running Fedora 39 on my AMD FW 13 using Wayland. In almost all system apps, including gnome apps, track pad scroll speed is basically normal and works almost as well as Windows. (d*mn you MS with your buttery-smooth precision drivers) Everything but Firefox (and gnome document viewer), is insanely sensitive on every distro that I try out. To work around Firefox’s weird behavior with track pads, I recommend tweaking the following settings to adjust scrolling strength:

about:config → Accept the Risk and Continue → set the following variables:

  • mousewheel.default.delta_multiplier_y (set value to ~25)
  • mousewheel.default.delta_multiplier_x (set value to ~25)
  • mousewheel.default.delta_multiplier_z (set value to ~25)

One down-side to this work-around is that scroll speed becomes very slow when plugging in and using a mouse. To bring it back to normal, you need to revert the variables back to default. Doing this is really annoying. I am currently exploring if there is a way to trigger the assignment of specific Firefox variables based on certain hardware that I use on my machine. So far, no luck.

1 Like

Hi @Matt_Hartley

Thanks for the quick and very detailed response. Just getting official word from yourself has actually put my mind at rest - I wasn’t 100% if this was a wider issue affecting all Ubuntu installs or just something myself and a few unfortunate folk had come across.

I’ve heard many a good thing about yourself across these forums and other locations, such as Reddit, so thanks again from chiming in for me here. I’ll definitely file a bug report with Ubuntu as per your suggestion.

I’ll not be trying any of those other “maybe” workarounds. As you say; it won’t be supported if it goes sideways, so I’m happy to leave well enough alone seeing as this is a known issue Hey, maybe it’ll be resolved come 24.04 LTS.

Thanks @moody_influence, appreciate that. I hear you on this, I do. Wasn’t too many years ago when trackpad functionality was rough on laptops, today, it’s so, so much better. So ideally libinput will continue to improve.

1 Like

Oh I totally agree. I’ve come from a 5-year-old Lenovo Yoga with Pop_OS and the trackpad is… functional. But the trackpad functionality with Ubuntu on the FW13 is a dream! (ignoring the scrolling speed). The three-finger swipe for the Gnome desktop is so slick.

1 Like

Note that this is fixable with Firefox flags, or with a compositor like Hyprland.

1 Like

Thanks @Shiroudan
I’ve made the tweak for Firefox but my original query was with the hope of finding a fix for the default Ubuntu Gnome globally.

I wasn’t aware of Hyprland so I’ll take a look at that if I’m feeling brave.

1 Like

hi @moody_influence, what was the fix for firefox? I’m having the same trouble but most of my work in Ubuntu is on Firefox so this would solve most of my problems and would be much appreciated!

Hi @fe1i
I changed mousewheel.default.delta_multiplier_y to 30 in about:config
The default is 100.

This is fine for when I’m using the touchpad but I have to revert the setting when I’m docked and using my mouse/trackball, as it’s too slow when not using the touchpad.

Keeping my fingers crossed for a global Wayland fix in 24.04 LTS.

Gnome team got a huge donation recently, and are using those added funds to go hard at work on improving accessibility within the desktop environment. Maybe this will include fixes to this input method? We’ll have to wait and see.

1 Like

I really hope in the next few years the Ubuntu trackpad experience can get to Mac OS level… I am getting carpal tunnel when I use my framework for extended periods due to the scroll and other things, it’s my only downside to the laptop currently.

I’m able to be so accurate and such high tracking speed on Mac that I don’t move my wrist.

1 Like

I’ve had my Framework 13 AMD since late October, and originally I just fixed the scrolling-too-fast problem in Firefox with the mousewheel.system_scroll_override.* settings. I didn’t have much problem with it after that, since almost all my scrolling is in Firefox or Terminal where there’s no “momentum” so it seems fine. But recently I was struggling with viewing PDFs in Evince - I can kinda get used to the scroll speed, with very small movement, but if I pick up my fingers too soon, the pages fly by due to “momentum”. Anyway, searching around, I found a good solution (if you’re using X11). TL;DR:

/etc/X11/xorg.conf.d/99-custom.conf

Section "InputClass"
        Identifier "libinput touchpad catchall"
        MatchIsTouchpad "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
        # Default is "15", higher number means slower scrolling
        Option "ScrollPixelDistance" "40"
EndSection

(That applies when X11 starts, to try on the fly see xinput commands below.)


I’m running Cinnamon desktop under X11 (150% fractional scaling works!) on Arch Linux.

I found some stackoverflow answers that suggested looking for xinput properties to adjust:

$ xinput list
...
⎜   ↳ PIXA3854:00 093A:0274 Touchpad          	id=11	[slave  pointer  (2)]
...
$ xinput list-props 11
Device 'PIXA3854:00 093A:0274 Touchpad':
	Device Enabled (167):	1
	Coordinate Transformation Matrix (169):	1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
	libinput Tapping Enabled (323):	0
	libinput Tapping Enabled Default (324):	0
	libinput Tapping Drag Enabled (325):	1
...
	libinput Drag Lock Buttons (298):	<no items>
	libinput Horizontal Scroll Enabled (299):	1
	libinput Scrolling Pixel Distance (321):	15
	libinput Scrolling Pixel Distance Default (322):	15
	libinput High Resolution Wheel Scroll Enabled (300):	1

The Scrolling Pixel Distance is indeed the one to go for. Try modifying it:

$ xinput set-prop 11 321 40

For the reference for the bit of X11 config we’re overriding, see /usr/share/X11/xorg.conf.d/40-libinput.conf (but don’t modify files in /usr/..., modify in /etc/...).

The last tip I needed was from (Solved) [libinput] [Linux Mint 21.3 Cinnamon] Touchpad scroll speed is too fast/sensitive - Linux Mint Forums - I first tried reducing the number, and that didn’t work. You need to increase it! It’s not screen pixels per scroll unit, it’s touchpad “pixels” per scroll unit.

I hope that helps someone :slight_smile:

How can you tell if you’re using X11?

On the login screen, there is probably a gear icon or similar, where you select the desktop environment, and the options may mention Wayland or Xorg (and if the other option you don’t use is Xorg, you can guess the option you use is Wayland). Also, some environment variables are indicators, and you can see them in a terminal, for example:

echo $XDG_SESSION_TYPE

(or just run env to see them all)

Unfortunately, this is actually quite an easy issue to solve. It’s just no one wants to do it.
There was a pull request a while back, but it got blocked because some Gnome developer believed any and all trackpad speed adjustments should be handled by libinput—which has a tiny bit of merit since that’s what handles acceleration profiles—but every other compositor/DE can handle it by itself.
Libinput has responded to this and said they don’t plan on incoporating trackpad scroll speed since they believe that is is too high level.

Unfortunately, from my experience this is pretty common with Gnome. They miss out on many things and refuse to go along with the flow of the Linux desktop space.

1 Like

I used this in the past, with Fedora 39, but haven’t used it recently:

It is however no longer maintained.

That’s really too bad. It feels like Linux is getting closer and closer to a spot where normal people could think about running it, but then there’s just weird hitches you run into that can make using it kinda a drag

Great to find this post and a reply from a Framework team member.

That’s a bad issue that will keep me for recommending Linux to not tech savvy friends. Shame, but I hope we get there one day. I am current using X11 to bypass it but the lack of gestures plus a bug with the amd gpu makes things harder.