Looking for help adjusting trackpad scroll speed on Ubuntu

Apologies is this is too much of a software question, I am running Ubuntu 21.04 on my Framework laptop and am finding the scroll speed, as I use two fingers and scroll up and down, moves the scroll bar way too fast for my liking and I’m not sure what to look for to change such behavior.

I’m a MacOS refugee and and slowing finding my way around so any tips or suggestions, very welcome.


Two places to check: Mouse and touchpad settings and GNOME tweaks tool. Also try turning off PS2 emulation in BIOS settings.

I have the tweaks app installed and it did come in handy for some things but does not seem to surface the value I am looking for. Nor did Settings. I’ll keep my eye out for that BIOS setting.

I’m running Pop OS, so similar but not exactly the same as Ubuntu. I have a setting in the Settings app for touchpad speed as well as one in gnome tweaks for the mouse acceleration. I’m not sure if that one has any affect on the touchpad speed but it won’t hurt to try.

In my experience the touchpad speed in Settings is more about single finger pointer movement, not two finger scroll speed. I think this bug is a deeper issue from some of the early links I’ve found. :thinking:

1 Like

I’m intrigued — I had Ubuntu 21.04 on my Framework for a few weeks but I didn’t have this fast scrolling problem. Do you see this everywhere or is it specific to certain apps? What does sudo libinput list-devices | grep Size say? (Mine says 111x73mm) FWIW, I’m on libinput v1.18.1.

Interesting, thanks. I am using wayland and hadn’t noticed an issue with the two finger scrolling speed, but I may just not be paying close enough attention. I’ll be following this thread to see where it goes.

I primarily feel it day to day in Firefox but even when I open up a longer VS Code document I can experience it there as well. It’s a system issue not an application issue best I can tell.

I had to install the libinput-tools to show this, but this is what I see:

zorn@framework:~$ sudo libinput list-devices | grep Size
Size:             111x73mm

For Firefox specifically, assuming you’re using Wayland, try disabling mousewheel.system_scroll_override.enabled and apz.gtk.kinetic_scroll.enabled in about:config and see how that feels.


Gave this a try and did not notice any behavior change. Thanks anyways.

I have this problem as well and haven’t been able to find a solution. It seems silly that gnome doesn’t just have a slider for this, but it means I have to scroll very carefully otherwise I will overshoot things. It really makes using Ubuntu feel unpolished right now. I tried the firefox specific settings but didn’t get anything to change there.


Sorry I am late to the game, you can adjust it usually in the Gnome Tweaks tool, but if you need to install the Touchpad Indicator there you can adjust it as well, but that works best with the Unity Desktop Environment.

Also what version of Ubuntu are you running 21.04 or 21.10? Because I am having no issues on my regular laptop. It could be something related to the ELAN Touchpad equivalent driver on Linux. I would seriously look into reinstalling the touchpad driver. Also installing the hardware drivers within the Software and Drivers help as well.

You should also check possibly for broken packages related to this issue in the Synaptic Package Manager and or restarting the touchpad driver.

This is with 21.04 in Gnome. There isn’t an option in Gnome Tweaks that I know of for us at least.

1 Like

I too am on Ubuntu 21.04 and can not find any such slider in the tweak app.

Anyone figure something out here? I haven’t been messing with it much as I am working mostly in docked mode these days, but scrolling on the trackpad remains overly sensitive all the time for me, I now have PS/2 emulation disabled and am running all the latest stuff on 21.04.

1 Like

Maybe try out the Ubuntu support forums? Speaking for myself, I’m not having any issues with Gnome 40 on Debian, but it may be that my idea of “overly sensitive” isn’t the same as yours and my machine is, in fact, behaving exactly the same and I just happen to like it. :slight_smile:

I have been messing around with this project- it seems like this is clearly a gnome/wayland issue that I haven’t run into before because I have been using 20.04 up until now (which uses xorg by default)

1 Like

That’s a nice find! That got me curious, and I ran across this clever little hack, in case folks aren’t comfortable adding that project to their system for whatever reason:

The gist is they override the detected trackpad dimensions, which affects the scroll speed, and then make the change persistent using a udev script.

This worked for me!
I set ‘scroll-factor=.2’ which seemed to do the trick. Totally useable scrolling now on wayland.


For Firefox specifically, assuming you’re using Wayland, try disabling mousewheel.system_scroll_override.enabled and apz.gtk.kinetic_scroll.enabled in about:config and see how that feels.

This fixed it for me. I was getting insane scroll speeds in Firefox on Ubuntu 21.04