[RESPONDED] Ubuntu instructions caused a major problem - close laptop causes freeze

Framework, recently sent me an email with this link in it to ‘improve’ my Ubuntu setup:

OK - I foolishly trusted the instructions. Before the instructions my laptop was working fine - really. I had Ubuntu 22.04 LTS installed and running fine. It was using the generic kernel.

I could close the lid on my laptop with zero errors.

The only thing that was sub optimal was battery life, which the help guide said the install instructions could improve.

I copied and pasted the below and now EVERY TIME I close my laptop. It freezes and I must hold down the power button for a hard reboot.

HELP Please

Also, do not send such an email unless the instructions are fail proof.

sudo apt update && sudo apt upgrade -y && sudo apt-get install linux-oem-22.04 && echo “options snd-hda-intel model=dell-headset-multi” | sudo tee -a /etc/modprobe.d/alsa-base.conf && gsettings set org.gnome.mutter experimental-features “[‘scale-monitor-framebuffer’]” && sudo sed -i ‘s/^GRUB_CMDLINE_LINUX_DEFAULT.*/GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash module_blacklist=hid_sensor_hub nvme.noacpi=1”/g’ /etc/default/grub && sudo update-grub &&
echo “[connection]” | sudo tee /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf && echo “wifi.powersave = 2” | sudo tee -a /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

Did you read the commands and understand what they were doing? My guess is not. This is Linux, you are ultimately repsonsible for the health of your system, and no instructions will ever be foolproof simply because of the number of different potential hardware configurations. So you copy and pasted without doing your homework and you broke your system. You are responsible, no one else. Get that straight.

Sorry for being harsh but really no one else typed in your sudo password. That being said edit /etc/default/grub and remove the nvme.noacpi=1 from the GRUB_CMDLINE_LINUX_DEFAULT line. Then sudo update-grub and it should rebuild the grub configuration so the change takes hold. Then reboot. A number of drives have an issue with that kernel parameter. Also verify your firmware on your drive is up to date… my guess is it is one of the Western Digital drives…lastly I generally recommend making sure you have the latest stable BIOS.

Finally are trying to run the laptop with the lid closed or is it crashing when you open it? Regardless the above kernel parameter is what is likely causing suspend to break. If you don’t want it going into suspend when the lid is closed you will simply need to turn that off in gnome-tweak or by editing some settings in sytemctl. Anyway hope that helps.

1 Like

@nadb Thank you for your reply. That seems to have fixed it.

I did, infact, lookup every item in the change list and felt that I understood the intent. I appreciate your sentiment. I was a code contributor to kernel code on AT&T System V and BSD 4.1. I fully confess to be a backend UNIX person with 40 years of coding and system admin.

The frontend systems - especially laptop hardware, have always been a ‘consumer’ experience for me on UNIX systems - they remain so. I run 20 commits every day, and not one ‘desktop’ commit in 40 years. So forgive me, please, for asking for help.

By using the word ‘foolishly’ in my comments, I had thought that I would prevent the kind of scolding you gave.

Thank you for the fix. It seems to have worked thus far.

Again, I would like to point out, these instructions were sent in an email from Framework in an email on 15 February. I see that there has been no comment on that fact.

I will now treat all such online guides at Framework, even apparently fully vetted ones, with grave suspicion.


Lol. Sorry. My Archlinux roots are showing. Linux Sysadmin, can’t afford to break stuff in production so I like to be extra sure before I pull the trigger on anything…especially when I don’t have a test host to break instead. Anyway feel free to tag me if you run into any other odd issues.


Happy to clarify.

These guides are used all day, every day by myself and others without incident. That said, there are occasions where something needs to be removed to resolve an issue.

As @nadb points out, there are some drives that don’t behave kindly with nvme.noacpi=1 - I’ve not run into it personally, but nabd’s instructions are sound and will eliminate something that may be negatively affecting your installation.

And that is your right. However, we use these all day, every day and they are heavily vetted and tested. This, sounds like a reaction to a current user config or a specific drive. I’d start by reading through nadb’s suggestions.

But on clean installations, the guides work and have been demonstrated to work reliably in most situiations. :slight_smile: