[RESPONDED] USB Software Defined Radio Errors

Recently ordered and received my new Framework Laptop, and it looks like I’m running into the USB issue that a few others have mentioned here. I’m trying to use my Ettus B205mini-i with my Laptop, but it disconnects as soon as I try to interface with it. It picks it up as connected, lsusb confirms the device was picked up, but trying to interact with it in anyway causes it to lock up and eventually disconnect. That usually results both slots on that side being unusable. Reloading udev, or rebooting are the only ways to get those slots back.

I have tried a bunch of the things listed in other posts, but I can’t seem to get it to work.
I have tried moving the expansion card to all slots, but that doesn’t seem to change anything. Plugging the SDR into a USB A to USB C adapter works on first connection, but any subsequent reconnects fail in the same way. The only way that seems to consistently work is plugging the device slowly into the port.

Laptop Specs:
Intel i7-1185G7
32 GB Ram
1 TB Storage
Ubuntu 20.04 LTS
Kernel 5.18.6-051806-generic
BIOS 3.07
Ordered/Delived in June.

1 Like

Hi and welcome to the forum.
I have little idea of what the mini radio is or is like.

The two things that come to mind are

  • you could use Ubunti 22.04 maybe that has better drivers etc
  • This page I found which maybe the Radio you have. There’s a lot of stuff to read there :blush:

What is it used for? :slight_smile:

If you have an external powered USB hub, give that a go from there. Power draw demand / peak / fluctuation may not be the Framework Laptop best friend.

(There was an early thread on USB disconnects. voltage…etc).


The B205 is a Software Defined Radio (or SDR). They’re used for amateur radio, and can be tuned to pick up anything between 30-6000 MHz. So they can grab AM/FM, amateur radio, Bluetooth, Wifi, etc.

I’ll have to try a powered hub next!

1 Like

This was the post / question:

Interesting. I use a 2021/07 manufactured RTL-SDR V3 with my Framework. I have not noticed this issue, but I am going to be using the SDR this weekend and will try to duplicate your issue to see if it is common.


Did some further testing, and using an externally powered USB hub seems to mostly solve the issues I’ve seen. But that defeats the freedom of using a laptop. I tried the USB EMF shield fix, and all but one looked fine. Fixing the one messed up one didn’t seem to change anything though.

1 Like

BIOS 3.09 beta just got released. Maybe you can give that a try. Specifically looking at Fix number 10.

BIOS 3.09 Beta release - Framework Laptop - Framework Community

Installed the BIOS Update, and reinstalled all of my drivers, and it looks like I’m still having issues getting it to work. Behavior doesn’t look like it changed at all. Still disconnecting when trying to use the device.

1 Like

But your success rate is improved when used with a powered USB hub?

Yeah, its much more stable on an externally powered hub. The voltage is also more stable. When I’m plugged in without a hub, it sits at 5.04. But it sits at 5.1-5.12 volts when using a powered hub. That’s at idle too.

1 Like

All this time, I’ve not seen Framework comment on the voltage thing. Maybe I’ve missed it.

Still, since it’s been a rather long standing issue (not just for your SDR)…it seems like Framework isn’t fixing / can’t fix it.

Hi im using a nesdr noolec sdr and i cant even get the device to show up in an sdr program on my intel 12th gen framework laptop i am going to try a bios update and let you know how that goes but i am also using the USB C > A module to connect my device.

I would echo in agreement, if a powered USB situation provides success, this is what is needed due to likely power draw.

This hasn’t solved my issue tho…