[RESPONDED] White screen after waking up from sleep


I have two Framework 13’’ AMDs, one is personal (DIY) and another (prebuilt) is for work.

I have found that the prebuilt hits white screens occasionally after it wakes up from sleep mode. The only thing I can do is power it down and reboot.

This problem doesn’t occur on my personal one, though I did have to follow a fix to get rid of white screen glitching when enlarging videos, etc… The fix has worked for that one.

I think the problem is described here quite well: Framework 13 Ryzen screen partially blanking white after resuming from sleep - #8 by Chopper_Rob .

Is anyone else finding this? Is there a solution for it.



Hi, i had experienced a kind off and i fixed setting up UMA_GAME_OPTIMIZED on bios.

Take a look to this thread [RESPONDED] Screen flashing partially white on Framework 13 AMD, Ubuntu 22.04 - #2 by Matt_Hartley

Not sure what OS you’re on, however, starting here is a good place to jump off from.

Thanks, I’ve tried the BIOS tweak.

I’m using Fedora 39. I should have mentioned that.


Can to please see if BIOS 3.05 clears up the white screen without any other workarounds?


Perhaps. I have tried the graphics RAM tweak above and I want to see if that works. So far it seems to. If that doesn’t I’ll look at upgrading the BIOS.


Both those other options are workarounds. The changes in bios 3.05 I’m expecting to be a fix. It looks promising so far from reports.

I think we are ordering more frameworks at work. I’ll look into the BIOS upgrade for the next one.