Right side of board does not recognize USB 3 or HDMI devices


Are you looking into the forum because you’re having potential issues with your Framework laptop? Before creating a post, we may have a guide, FAQ, or thread that can hopefully help!

In the body of your post, please include those following details.

  • Which OS (Operating System)?
  • Which release of your OS (Operating System / Windows 10, 11, Distribution of Linux)?
  • Which Framework laptop (11th, 12th or 13th generation Framework laptop) are you asking for support with?
  • If this is a Linux issue, please use the Linux tag or at least put Linux in the title.
  • If there is no information pertaining to your issue or question, please let us know here: Framework | Support Framework | Support

Windows 11
12th gen

I had a ticket open for HDMI expansion card and when I tried to use a USB 3 capture card on my bottom right port, it did not recognize the device. However, I tried it on the left side and the device worked properly. After trying all four ports with this capture card, I discovered that the left two ports are not recognizing HDMI displays or the capture card but it will recognize charging. How do I fix this?

Can always try removing the CMOS to reset the BIOS. What BIOS version are you on?

But I can’t update it for some reason, it won’t let me

That’s pretty strange, does it give you an error code?