[RESPONDED] Right side ports suddenly stopped working. What trouble shooting steps should I take next?

Hey everyone.

I just noticed that my right-side USB ports no longer work in any way shape or form.

I cannot connect an external USB drive, nor charge the device.

Note that both right side ports are unresponsive.

I’ve exchanged the USB modules, and directly connected the drive and power cable without the module.

The Modules work fine but I still cannot charge nor get it to register the external drive.

The last time I remember using the right-side USB ports was when I charged the system for 36 hours following Framework’s troubleshooting customer service.

Since that time, I updated the Bios to the latest version, then replaced the Cmos battery(which solved the problem I was having).

But now, I’m having this new issue and I’m not sure how to solve this.

The machine was under no physical abuse to warrant such faulty behavior. I really have no clue why this is happening. If anyone knows what might be happening, please let me know.

Best regards,

First, did you contact support about your new issue?

This sounds like something that could be solved with a Motherboard reset, but maybe the Framework support knows something else to try before.

So, give them a go and tell us what they said,- there is not much more we (as the community) can do here to help you on these types of hardware issues.

not yet, I wanted to see what the community had to say before I contacted Framework support.

I would absolutely recommend reaching out to support first. This is my recommendation.

I also agree with this. Especially in the case of hardware issues (like this one) Framework support is going to be much more helpful than the community, and it will end up being quicker in the case that you end up needing a hardware swap.

I shit you not, the day I got a reply from support, the port magically started working again.
What the hell is going on?

Nevermind, it’s just their support mediums are that skilled :slight_smile:

Still sounds intermittent. If you’re unable to replicate it further, let support know. If it happens again and needs another ticket, mention you had a previous ticket for this issue and that it appears to be intermittent.