Screen tearing with Linux

I’ve experienced a lot of screen tearing on my Framework laptop. I have the 17-1165G7 version, 64GB of RAM. For example, when one window is behind another one and I bring it to the foreground, different sections of it appear at a time, and it can take up to 1.5 seconds for the window to be intact. Also sometimes I get duplicates of the mouse cursor when I move the mouse around. I noticed that regardless of the distribution, it seems the screen tearing only happens when I use the GNOME desktop environment.

I’ve tested Manjaro, Fedora, Debian, Pop!_OS, all with GNOME. I’m currently running Linux Mint. I was using GNOME on Mint for a while, but the screen tearing became a bigger issue than it was worth, so I switched to Cinnamon.

Has anyone else run into this issue, or know of a fix for it?

Have your tried disabling PSR as a starting point? If not, search the threads, the topic is beaten at this point!

Perhaps wait a few days for the Fedora 35 full release or install the beta if you’re feeling up for it (it’s pretty much entirely stabilized at this point and will be a seamless transition to the full release on launch day).

I’ve been running the beta largely without issue on the same i7, with a quarter the ram and GNOME 41 has been as smooth as butter. No PSR fix, and I have an informal stress test that basically involves layering all of my use cases at once forcing up 94% memory utilization and Fedora 35 with GNOME 41 continues to be smooth as butter under those condition

Definitely, definitely no screen tearing with a 1.5 second delay to sort itself out.

1 Like

Have you encountered it at all with Cinnamon? From what I understand its an issue with X11 but I suppose Cinnamon might already have a work around enabled if you haven’t encountered tearing since switching.

Cinnamon works great, without screen tearing. I would have thought GNOME wouldn’t have the issue, because the version I was using had Wayland, not X11. Though I haven’t tried any beta or development versions of any distro, so maybe it’s just an issue with less recent versions of GNOME.

I’ve tried disabling PSR with i915.enable_psr=0 (and recreating GRUB’s configuration file and rebooting), and that doesn’t seem to work for me. I’m still seeing some weird screen tearing around right-click menus in both GTK3 and QT applications.


I’d just like to note that I did end up fixing this issue using advice from this thread:

1 Like

Make sure you switch to Wayland at the login screen. X11 is known for screen tearing. Wayland fixes that fundamentally.

There is a feature that you might check, something to do with the refresh rate. Panel self-refresh:

This is true, it does solve the screen tearing issue, but text in for instance firefox is fuzzy with wayland (fractional scaling) and absolutely pin sharp with X11.

But even with psr off and/or 20-intel.conf (screen tearing off option for x11 from the Arch wiki) there is still screen tearing in X11.

Not much framework can do about it I guess, just annoying in the linux world. Still not solved after all this time.

I’m not sure if anyone need this, but I just fixed some pretty horrible graphical glitches I was having by updating my intel drivers for Ubuntu 22 did the trick. It seems like the latest update only came out a few days ago, so I hope this can help somebody else.

My problem was that in GPU acellerated apps (Chromium, Signal, Alacritty, etc.) entire portions of the screen wouldn’t even be rendered, resulting in this splotchy mess. I searched for “tearing” and didn’t get anything. I followed the links above to update the Intel drivers and all is well now.

I am running:
12th Gen Intel i7-1260P (16) @ 4.700GHz
OS: Linux Mint 21
WM: awesome

I’m being noticing that the Arch link about 20-intel.conf etc is leading to the use of the intel Xorg driver.

This is not a good idea, I’ve had tons of problems with the intel Xorg driver, and none with the modesetting driver (well, except the problem stemming from the Linux kernel version 5.19.12). I warmly encourage you to try out the modesetting driver, which is even the one advised to use with an Intel iGPU instead of the intel one. Reasons are: supports all if not more of the features the intel driver supports for the Intel iGPUs (and with much less problems).

The modesetting driver uses internally the Linux kernel’s drm module, which is scrutinized and improved in the very kernel mainstream branch, which is making it progress at a much faster pace than the intel driver.

This issue was driving me crazy, I really love my framework laptop so far, but this was the first time I’ve needed to use fractional scaling on a device. I guess Xorg is really starting to show it’s age.

I tried most solutions I’ve found looking around, and had no luck using the xorg intel driver, or playing around with any xorg, modesetting driver, or compositor settings to try to eliminate this screen tear while using fractional scaling. I stumbled upon a reddit post that provided a solution that seems to work, if anything a tiny bit janky.

Steps 4 and 5 in that post didn’t fix the tearing for me, but following step 6 did. To anybody trying this, initially step 6 didn’t, but some changes I had made to the compositor settings seemed to be conflicting, after rolling that back I got the scaling I need without the screen tear.

I’m running Mint 21.1 with Cinnamon. I plan on trying out something Arch based and seeing how Wayland works with KDE in the near future, but for now this fix seems to be working. I hope this helps somebody out who was as frustrated as I was, might be worth making a guide if it doesn’t cause any extra issues.

I’m running Mint 21.1 with Cinnamon. The only time I feel screen tearing is when using non-integer monitor scaling. For now I’ve left the scaling at 200% and configured apps to zoom out (if possible). Most browsers can be configured with a default scaling size (I use 80%) and electron apps can be zoomed out by using the usual shortcut combination of CTRL±.

started running into this when I upgraded to 13th gen. It never happened once on 11th gen.

I’ll notice:

  • booting OBS triggers it to be way worse
  • setting OBS to 30 fps down from 60 makes it way better
  • websites like youtube and twitch make it a good bit worse than strictly text websites.
┬─[qd@grindenstern:~/p/coq-numerics]─[01:57:03 PM]
╰─>$ nix-shell -p neofetch --run neofetch
          ▗▄▄▄       ▗▄▄▄▄    ▄▄▄▖            qd@grindenstern 
          ▜███▙       ▜███▙  ▟███▛            --------------- 
           ▜███▙       ▜███▙▟███▛             OS: NixOS x86_64 
            ▜███▙       ▜██████▛              Host: Framework FRANMCCP07 
     ▟█████████████████▙ ▜████▛     ▟▙        Kernel: 6.1.63 
    ▟███████████████████▙ ▜███▙    ▟██▙       Uptime: 21 hours, 22 mins 
           ▄▄▄▄▖           ▜███▙  ▟███▛       Packages: 1636 (nix-system), 6710 (nix-user), 13 (flatpak) ███▛             ▜██▛ ▟███▛                 
         ▟███▛               ▜▛ ▟███▛         Shell: bash 5.2.15 
▟███████████▛                  ▟██████████▙   Resolution: 2256x1504, 1920x1080 
▜██████████▛                  ▟███████████▛   DE: none+xmonad 
      ▟███▛ ▟▙               ▟███▛            WM: xmonad 
     ▟███▛ ▟██▙             ▟███▛             Theme: Adwaita-dark [GTK2/3] 
    ▟███▛  ▜███▙           ▝▀▀▀▀              Icons: breeze-dark [GTK2/3] 
    ▜██▛    ▜███▙ ▜██████████████████▛        Terminal: emacs 
     ▜▛     ▟████▙ ▜████████████████▛         CPU: 13th Gen Intel i7-1370P (20) @ 5.000GHz 
                                              GPU: Intel Raptor Lake-P [Iris Xe Graphics] 
                                              Memory: 7597MiB / 64027MiB (11%) 
                                              GPU Driver: i915 
                                              Disk (/): 350G / 1.8T (21%) 
                                              Battery1: 100% [Not charging] 
                                              Font: Noto Sans, 10 [GTK2/3]

update: screen tearing on a fresh ubuntu 23 gnome default install partition, so it’s not my config.