Solus Compatibility on The Framework Laptop

I was wondering if there are any issues with running Solus on the Framework laptop.

Solus should work, there may be some packages that won’t work with Framework laptops yet. (Mostly pointing to libfprint, which is the library which handles fingerprints).

I’ll be installing Solus Budgie once my DIY arrives and is assembled. I’ll post back here with an update.

1 Like

@Water261 Thanks for letting me know this. However it seems solus does actually have the libfprint library so that should work although I’m not sure how up to date it is haha. However what I’m worried about it driver issues for the most part now. Since one other distros some seem to work without issues while others do not.

@Jonathan_Williams thanks!

Last night I installed Solus 4.3 via USB and brought it up to date. Everything is working very well so far. No issues with wifi, bluetooth, sound. Display is running at 2256 x 1504 with 200% scaling and looks great to me.

Libfprint is at 1.90 in the Solus repository so I’m ignoring the fingerprint reader for now.

I had one instance of the trackpad not responding after coming out of suspend but this doesn’t seem to have happened again.

From what I’m seeing so far Solus looks like a very good option for the Framework.

3 Likes

So essentially it is just like Ubuntu 21.04 as the fingerprint doesn’t work! Thanks for your input!

I would have thought 200% scaling is too high.

It certainly is on windows.

Yes, dimensionally it’s fine. I would probably prefer 150% scaling but 100% and 200% are the only options.

I’m using Budgie. It doesn’t seem that there is any way to do fractional scaling of the entire screen.

I also tried leaving scaling at 100%, setting text scaling to 2, and increasing the size of the panel. This works with a few quirks such as the system and notification icons in the panel stay small while the app and pinned icons get larger.

Scaling in linux is really bad currently (or I have not found a good option). ChromeOS really figured it out. I’m using Ubuntu right now on my Framework and at 125% / 150% things are pretty fuzzy.

Fprintd and libfprint recently updated in the Solus Shannon repository and with some simple configuration I’ve got login, sudo, and screen lock working with the fingerprint reader.

With that, everything on the Framework is working more or less out of the box with Solus.

I tried installing Solus Plasma 4.3 on my 12th gen Framework today. Unfortunately it seems to be stuck on the init screen. Even waiting for a couple of minues doesn’t show any progress. Not sure how to proceed. Any tips?

What are you installing from?

A USB stick in the top right slot.

It starts the boot and after choosing the option “Solus 4.3 (Plasma)” then there’s just two errors about thunderbolt (thunderbolt 0-0: reading DROM failed), which I think makes sense, as no thunderbolt devices are connected, and nothing else happens.

I have no specific ideas about what’s happening but I might try making another installer on a different USB drive and/or moving the USB module to a different slot.

I tried another USB stick with the image flashed on it in both the top left and top right USB ports. So far no luck. Still stuck during boot.

I’m having the same problem with my framework 12th gen. It gives me the thunderbolt 0-0: reading DROM failed as well as a TPM tpm0 [firmware bug] TPM interrupted trying polling instead. Tried with the plasma and budgie versions and had the same bug on both.

Mine is 11th gen and I’ve never had any issues like this during installs. Currently running Solus fully updated with no problems though I haven’t done an install from scratch in a while.